Ignore:
Timestamp:
Feb 8, 2005, 11:27:36 PM (15 years ago)
Author:
jberry
Message:

Switch to use of rmp-vercomp for ant version checking. This allows better compatibility with future versions of ant.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/java/tomcat5/Portfile

    r10876 r10878  
    1 # $Id: Portfile,v 1.11 2005/02/08 23:06:45 jberry Exp $
     1# $Id: Portfile,v 1.12 2005/02/08 23:27:36 jberry Exp $
    22
    33PortSystem 1.0
     
    5656
    5757# Tomcat in this version requires ant 1.6.2.
    58 # If the current version of ant is not 1.6.2 then add an
    59 # explicit dependency onto our ant port to get 1.6.2.
     58# If the current version of ant is not at least 1.6.2 then add an
     59# explicit dependency onto our ant port.
    6060if { [string length [auto_execok ant]] } {
    6161        set verOutput [exec ant -version]
    6262        regexp {version (\d*(\.\d*(\.\d*)?)?)} $verOutput -> antVersion
    63         if { $antVersion != "1.6.2" } {
     63        if { [rpm-vercomp $antVersion "1.6.2"] < 0 } {
    6464                depends_build-append bin:XXX:apache-ant
    6565        }
Note: See TracChangeset for help on using the changeset viewer.