Changeset 110324


Ignore:
Timestamp:
Aug 29, 2013, 10:49:06 PM (6 years ago)
Author:
jeremyhu@…
Message:

krusader: Not supported on Mavericks

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/kde/krusader/Portfile

    r97488 r110324  
    4444# krusader/Dialogs/checksumdlg.cpp:32:61: error: default arguments can only be specified for parameters in a function declaration
    4545#   const QString checksumFile, bool recursive, const QString& type=QString());
    46 if {${configure.compiler} == "clang"} {
    47     configure.compiler  llvm-gcc-4.2
     46compiler.blacklist-append *clang*
     47
     48platform darwin {
     49    if {${os.major} >= 13} {
     50        # TODO: Test Mavericks once the clang build failures are addressed
     51
     52        depends_lib
     53        depends_run
     54        pre-fetch {
     55            ui_error "$name does not build on Mavericks or later."
     56            error "unsupported platform"
     57        }
     58    }
    4859}
     60
    4961
    5062# awful hack to avoid meinproc crash, ticket #30162
Note: See TracChangeset for help on using the changeset viewer.