Changeset 112148 for trunk/dports/aqua


Ignore:
Timestamp:
Oct 13, 2013, 11:28:45 PM (6 years ago)
Author:
ryandesign@…
Message:

Quicksilver: use the MacOSX10.8 SDK on 10.7

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/aqua/Quicksilver/Portfile

    r112146 r112148  
    66PortGroup               github 1.0
    77PortGroup               xcode 1.0
     8PortGroup               xcodeversion 1.0
    89
    910# The developer states it is not possible to provide tags for 1.1.x > 1.1.0.
     
    4849}
    4950
     51# Quicksilver uses new Objective-C features which require the MacOSX10.8 SDK when compiling on 10.7.
     52minimum_xcodeversions {11 4.4}
     53platform darwin 11 {
     54    configure.sdkroot ${developer_dir}/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.8.sdk
     55}
     56
    5057# Blacklist compilers that don't support new Objective-C features.
    5158# Blacklisting does not work because xcode portgroup doesn't recognize MacPorts compilers.
Note: See TracChangeset for help on using the changeset viewer.