Changeset 112449 for trunk/dports/ruby


Ignore:
Timestamp:
Oct 23, 2013, 2:35:18 PM (6 years ago)
Author:
kimuraw@…
Message:

ruby/rb19-nokogiri, rb-nokogiri: upgrade to 1.6.0, fix build failure against current version of libxml (#40836)

Location:
trunk/dports/ruby
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/ruby/rb-nokogiri/Portfile

    r106533 r112449  
    44PortGroup               ruby 1.0
    55
    6 ruby.setup              nokogiri 1.4.6 gem {} rubygems
    7 revision                1
     6ruby.setup              nokogiri 1.6.0 gem {} rubygems
     7revision                0
    88maintainers             kimuraw openmaintainer
    99description             Nokogiri is an HTML, XML, SAX, and Reader parser.
     
    1313license                 MIT
    1414platforms               darwin
    15 depends_lib-append port:libxml2 port:libxslt
     15homepage                http://nokogiri.org/
     16checksums           md5     3f60f47e19e5e7ebff3f9480305de1ed \
     17                    sha1    ce635b121e9bc621794a54e610bcf7fe4b7d7e82 \
     18                    sha256  abc5f9acb29a92d041ce7ed1a0ea6ca7e4bf66c3bc60cf4ebda041c193b799c5 \
     19                    rmd160  e5aab115eb2be18b8cfd08f0fd785aad243d31dd
    1620
    17 homepage                http://nokogiri.org/
    18 checksums               md5 8e0a33db6a237d7d7d3c25db5c47e769 \
    19                                 rmd160 79ad05d4f2ddf26bee35f5730628ad3e989494f8 \
    20                                 sha1 103bb4482b19b617d5c4e592b8ce2ed4e111d3cb
    21 
     21depends_lib-append  port:libxml2 \
     22                    port:libxslt \
     23                    port:zlib \
     24                    port:libiconv \
     25                                        port:rb-mini_portile
     26destroot.env-append NOKOGIRI_USE_SYSTEM_LIBRARIES=YES
  • trunk/dports/ruby/rb19-nokogiri/Portfile

    r106535 r112449  
    44PortGroup                   ruby 1.0
    55
    6 ruby.setup          nokogiri 1.4.6 gem {} rubygems ruby19
    7 revision                        1
     6ruby.setup          nokogiri 1.6.0 gem {} rubygems ruby19
     7revision                        0
    88description                 HTML, XML, SAX, & Reader parser with XPath/CSS3 selector searching
    99long_description        \
     
    1717homepage                    http://nokogiri.org/
    1818categories-append   xml
    19 checksums           md5     8e0a33db6a237d7d7d3c25db5c47e769 \
    20                     sha1    103bb4482b19b617d5c4e592b8ce2ed4e111d3cb \
    21                     rmd160  79ad05d4f2ddf26bee35f5730628ad3e989494f8
     19checksums           md5     3f60f47e19e5e7ebff3f9480305de1ed \
     20                    sha1    ce635b121e9bc621794a54e610bcf7fe4b7d7e82 \
     21                    sha256  abc5f9acb29a92d041ce7ed1a0ea6ca7e4bf66c3bc60cf4ebda041c193b799c5 \
     22                    rmd160  e5aab115eb2be18b8cfd08f0fd785aad243d31dd
    2223
    2324depends_lib-append  port:libxml2 \
    24                     port:libxslt
     25                    port:libxslt \
     26                    port:zlib \
     27                    port:libiconv \
     28                    port:rb19-mini_portile
     29destroot.env-append NOKOGIRI_USE_SYSTEM_LIBRARIES=YES
Note: See TracChangeset for help on using the changeset viewer.