Changeset 113211 for trunk/dports/aqua


Ignore:
Timestamp:
Nov 12, 2013, 2:00:20 PM (6 years ago)
Author:
michaelld@…
Message:

qt4-mac: correctly compare strings, using eq and ne.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/aqua/qt4-mac/Portfile

    r113188 r113211  
    293293# hopefully the macosx_deployment_target exists and is set by now.  if
    294294# not, last resort (which is not desirable) is to use the os.version.
    295 if {${macosx_deployment_target} != ""} {
     295if {${macosx_deployment_target} ne ""} {
    296296    set MINOR [lindex [split ${macosx_deployment_target} "."] 1]
    297297} else {
     
    305305global SDK
    306306set SDK ${configure.sdkroot}
    307 if {${SDK} == ""} {
     307if {${SDK} eq ""} {
    308308    # set SDK version depending on OS version
    309309    set sdk_version ""
    310     if {${MINOR} == "4"} {
     310    if {${MINOR} eq "4"} {
    311311        # OSX 10.4 requires an additional 'u'
    312312        set sdk_version "10.4u"
     
    559559    # for 10.4 or 10.5 32-bit PPC, build as Carbon only, not Cocoa
    560560
    561     if {${MINOR} == "4"} {
     561    if {${MINOR} eq "4"} {
    562562
    563563        configure.args-append -carbon
     
    568568            -lssl -lz
    569569
    570     } elseif {${MINOR} == "5" &&
     570    } elseif {${MINOR} eq "5" &&
    571571              [llength ${qt_arch_types}] == 1 &&
    572572              [lsearch -exact ${qt_arch_types} ppc] == 0} {
     
    594594        configure.args-delete -optimized-qmake
    595595
    596     } elseif {${MINOR} == "6" &&
     596    } elseif {${MINOR} eq "6" &&
    597597              [llength ${qt_arch_types}] == 1 &&
    598598              [lsearch -exact ${qt_arch_types} x86] == 0} {
     
    620620        if {[info exists configure.cxx_stdlib]} {
    621621            configure.env-append QMAKE_STDLIB="-stdlib=${configure.cxx_stdlib}"
    622         } elseif {${MINOR} = "9"} {
     622        } elseif {${MINOR} eq "9"} {
    623623            configure.env-append QMAKE_STDLIB="-stdlib=libc++"
    624624        } else {
     
    10171017    # conflict between it and this port.
    10181018    if {[file exists ${prefix}/bin/qt4_select]} {
    1019         if {[exec ${prefix}/bin/qt4_select -s] != "none"} {
     1019        if {[exec ${prefix}/bin/qt4_select -s] ne "none"} {
    10201020            ui_msg "Disabling 'qt4_select' selection."
    10211021            system "exec ${prefix}/bin/qt4_select none"
     
    10651065}
    10661066
    1067 if {${psql_version} != ""} {
     1067if {${psql_version} ne ""} {
    10681068    ui_error "${name} variant +psql${psql_version} has been replaced by the port 'qt4-mac-postgresql91-plugin' and its subports.  Please install ${name} without +psql${psql_version}, then install your desired PostgreSQL Qt plugin."
    10691069    return -code error "Variant disabled"
Note: See TracChangeset for help on using the changeset viewer.