Changeset 113328


Ignore:
Timestamp:
Nov 13, 2013, 4:37:22 PM (6 years ago)
Author:
devans@…
Message:

libpanel-applet2: obsolete, replaced by gnome-panel.

Location:
trunk/dports/gnome/libpanel-applet2
Files:
1 deleted
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/gnome/libpanel-applet2/Portfile

    r107312 r113328  
    44PortSystem      1.0
    55
     6replaced_by     gnome-panel
     7PortGroup       obsolete 1.0
     8
    69name            libpanel-applet2
    7 set gname       gnome-panel
    8 #
    9 # This is the last version of gnome-panel that provides libpanel-applet-2.0
    10 # installs libpanel-applet-2.0 only. Newer libpanel-applet-3.0 provided
    11 # by later gnome-panel versions installs in parallel without conflict.
    12 #
    1310version         2.30.2
    14 set branch      [join [lrange [split ${version} .] 0 1] .]
    15 maintainers     devans openmaintainer
    16 categories      gnome
    17 license         GPL-2+ LGPL-2+
    18 platforms       darwin
    19 description     Legacy libpanel-applet-2.0 for the GNOME 2 Desktop.
    20 
    21 long_description \
    22                 ${description}
    23 
    24 homepage        http://www.gnome.org/
    25 master_sites    gnome:sources/${gname}/${branch}/
    26 
    27 distname        ${gname}-${version}
    28 
    29 use_bzip2       yes
    30 
    31 checksums       md5     11b6db12223c70a218a2f4602b1683cc \
    32                 sha1    4be902269d4dd4af1e988d522ae613946890ec0a \
    33                 rmd160  b5828e0235a6fb5faa011179ff8fcc0574bf3c6b
    34 
    35 depends_build   port:pkgconfig \
    36                 port:intltool \
    37                 port:gnome-doc-utils \
    38                 port:gtk-doc \
    39                 port:shared-mime-info
    40 
    41 depends_lib     port:gnome-desktop \
    42                 port:gnome-menus \
    43                 port:policykit-gnome \
    44                 port:libbonoboui \
    45                 port:libcanberra \
    46                 port:librsvg \
    47                 port:libwnck \
    48                 port:libgweather
    49 
    50 patchfiles      patch-configure.diff \
    51                 patch-Makefile.in.diff
    52  
    53 configure.args  --x-includes=${prefix}/include \
    54                 --x-libraries=${prefix}/lib \
    55                 --with-in-process-applets=none \
    56                 --disable-scrollkeeper \
    57                 --disable-silent-rules \
    58                 --disable-eds \
    59                 --disable-network-manager \
    60                 --disable-schemas-install
    61 
    62 variant python25 conflicts python26 python27 description {Build using Python 2.5} {
    63     configure.python          ${prefix}/bin/python2.5
    64     depends_build-append      port:python25
    65 }
    66 
    67 variant python26 conflicts python25 python27 description {Build using Python 2.6} {
    68     configure.python          ${prefix}/bin/python2.6
    69     depends_build-append      port:python26
    70 }
    71 
    72 variant python27 conflicts python25 python26 description {Build using Python 2.7} {
    73     configure.python          ${prefix}/bin/python2.7
    74     depends_build-append      port:python27
    75 }
    76 
    77 if {![variant_isset python25] && ![variant_isset python26]} {
    78     default_variants +python27
    79 }
    80 
    81 post-destroot {
    82     file delete -force ${destroot}${prefix}/bin
    83     file delete -force ${destroot}${prefix}/share
    84 }
    85 
    86 livecheck.type none
     11revision        1
Note: See TracChangeset for help on using the changeset viewer.