Ignore:
Timestamp:
Nov 27, 2013, 4:20:17 PM (6 years ago)
Author:
michaelld@…
Message:

octave:
+ move octave-devel to octave;
+ set octave-devel as replaced_by octave;
+ fix all possible octave modules to work correctly under 10.8 and 10.9;
+ set remaining 3 octave modules as deprecated because they do not work with octave 3.6 or newer, and there is no easy means to address the errors.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/math/octave-arpack/Portfile

    r86937 r114034  
     1# -*- coding: utf-8; mode: tcl; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- vim:fenc=utf-8:et:sw=4:ts=4:sts=4
    12# $Id$
    23
     
    89license             GPL-2+
    910maintainers         nomaintainer
    10 description         Octave bindings to ARPACK, including the eigs and svds \
    11                     function.
     11description         Octave bindings to ARPACK, including the eigs \
     12                    and svds function.  This module has been \
     13                    integrated into Octave\; this port is being \
     14                    deprecated.
    1215long_description    ${description}
    1316
    14 checksums           md5     dbf767019e238c4a16ccc6cac2afe87c \
    15                     sha1    3fa7847b6bedb2379ff51399195481fbfe2e4b89 \
    16                     rmd160  0d16b935f72b8b7c32721216edf09935eeb8e50f
     17depends_build
     18depends_lib
     19depends_run
    1720
    18 depends_lib-append  port:arpack
     21pre-fetch {
     22    ui_msg ""
     23    ui_error "$name in integrated into Octave 3.6 and newer.\n"
     24    error "deprecated Octave module\n"
     25}
Note: See TracChangeset for help on using the changeset viewer.