Ignore:
Timestamp:
Nov 27, 2013, 4:20:17 PM (6 years ago)
Author:
michaelld@…
Message:

octave:
+ move octave-devel to octave;
+ set octave-devel as replaced_by octave;
+ fix all possible octave modules to work correctly under 10.8 and 10.9;
+ set remaining 3 octave modules as deprecated because they do not work with octave 3.6 or newer, and there is no easy means to address the errors.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/math/octave-graceplot/Portfile

    r86937 r114034  
     1# -*- coding: utf-8; mode: tcl; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- vim:fenc=utf-8:et:sw=4:ts=4:sts=4
    12# $Id$
    23
     
    89license             GPL-2+ public-domain
    910maintainers         nomaintainer
    10 description         Graceplot bindings for octave.
     11description         Graceplot bindings for octave.  This module does \
     12                    not work with Octave 3.6 or newer\; this port is \
     13                    being deprecated.
    1114long_description    ${description}
    1215
    13 checksums           md5     3e123bea0ab347e938758d9d3bf1d7a2 \
    14                     sha1    34bfd5073007fc3d5cf1a430176580907ac86d32 \
    15                     rmd160  8887482e2412974cf05f4eee7558f10e1e712b3e
     16depends_build
     17depends_lib
     18depends_run
    1619
    17 depends_lib-append  port:octave-io
     20pre-fetch {
     21    ui_msg ""
     22    ui_error "$name does not work with Octave 3.6 or newer.\n"
     23    error "deprecated Octave module\n"
     24}
Note: See TracChangeset for help on using the changeset viewer.