Ignore:
Timestamp:
Mar 22, 2014, 3:16:34 PM (5 years ago)
Author:
jmr@…
Message:

remove replaced_by upgrade path for old python24-using py-* ports, as all were renamed to py24-* over a year ago now

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/_resources/port1.0/group/python-1.0.tcl

    r116941 r118101  
    7272proc python_get_default_version {} {
    7373    global python.versions
    74     # py-foo historically meant python24, so we default to that if present
    7574    if {[info exists python.versions]} {
    76         if {[lsearch -exact ${python.versions} 24] != -1} {
    77             return 24
    78         } elseif {[lsearch -exact ${python.versions} 27] != -1} {
    79             # this is the actual preferred version
     75        if {[lsearch -exact ${python.versions} 27] != -1} {
    8076            return 27
    8177        } else {
     
    8379        }
    8480    } else {
    85         return 24
     81        return 27
    8682    }
    8783}
     
    10298            extract {}
    10399            supported_archs noarch
    104             global python.default_version
    105             if {${python.default_version} == "24"} {
    106                 replaced_by py24[string trimleft $name py]
    107             }
    108             global python.version
     100            global python.default_version python.version
    109101            unset python.version
    110102            depends_lib port:py${python.default_version}[string trimleft $name py]
     
    173165    if {[string match py-* $name]} {
    174166        if {$subport eq $name || $subport eq ""} {
    175             # Mark stub as replaced_by py24 subport if that's the
    176             # default version, for backwards compatibility.  If the
    177             # default version isn't 24, clear replaced_by -- it might
    178             # have already been set by python_set_versions. (But make
    179             # sure we've set it first, or unset might complain.)
    180             replaced_by py24[string trimleft $name py]
    181             if {${python.default_version} != "24"} {
    182                 global replaced_by
    183                 unset replaced_by
    184             }
    185167            depends_lib port:py${python.default_version}[string trimleft $name py]
    186168        }
Note: See TracChangeset for help on using the changeset viewer.