Ignore:
Timestamp:
Apr 3, 2014, 10:14:55 PM (5 years ago)
Author:
mojca@…
Message:

wxWidgets portgroup: remove wxPerl-3.0

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/_resources/port1.0/group/wxWidgets-1.0.tcl

    r115974 r118524  
    110110            }
    111111        }
    112     # support for wxPerl is just temporary until the upstream adapts wxPerl to be compatible with wxWidgets 3.0
     112    # support for wxPerl was just temporary
    113113    } elseif {${args} eq "wxPerl-3.0"} {
    114         wxWidgets.name      "wxPerl"
    115         wxWidgets.version   "2.9"
    116         wxWidgets.port      "wxPerl-3.0"
    117         if {${os.major} < 9} {
    118             pre-fetch {
    119                 ui_error "${wxWidgets.port} requires Mac OS X 10.5 or later."
    120                 return -code error "incompatible Mac OS X version"
    121             }
    122         }
     114        # throw an error
     115        ui_error "You shouldn't be using 'wxWidgets.use wxPerl-3.0' any longer. Switch to wxWidgets-3.0."
     116        return -code error "invalid parameter for wxWidgets.use"
    123117    } else {
    124118        # throw an error
Note: See TracChangeset for help on using the changeset viewer.