Changeset 119770


Ignore:
Timestamp:
May 6, 2014, 9:15:41 AM (5 years ago)
Author:
nicos@…
Message:

amarok-devel: making port obsolete as not maintained for a long time, replaced by amarok

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/kde/amarok-devel/Portfile

    r101405 r119770  
    22
    33PortSystem          1.0
    4 PortGroup           kde4    1.0
    54
    65name                amarok-devel
     6replaced_by         amarok
    77version             git-20090927
    8 revision            4
     8revision            5
    99categories          kde kde4
    10 conflicts           amarok
    1110maintainers         nomaintainer
    1211description         Amarok, the world-renowned media player.
     
    1615platforms           darwin
    1716homepage            http://amarok.kde.org
    18 master_sites        http://gitorious.org/amarok
    19 # The following are placeholders for official beta releases
    20 #master_sites       http://ftp.kde.org/unstable/${name}/${version}/src/
    21 #use_bzip2           yes
    22 #checksums           md5 410863050e5de95df82106cc9dfe486a
    23 distname            amarok
    24 fetch.type          git
    25 git.url             git://gitorious.org/amarok/amarok.git
    26 git.branch          33f852d6e293aa4632a4381d3468c7cf89224380
    27 worksrcdir          amarok
    2817
    29 depends_build-append port:git-core
    30 
    31 depends_lib-append  port:kde4-runtime port:kdelibs4 \
    32                     port:qtscriptgenerator port:liblastfm \
    33                     port:taglib port:taglib-extras \
    34                     port:loudmouth \
    35                     path:bin/mysql_config5:mysql5
     18distfiles
    3619
    3720pre-configure {
    38     if {![file exists ${prefix}/lib/mysql5/mysql/libmysqld.a]} {
    39         ui_error "${name} cannot be installed because MySQL was not installed with the libmysqld embedded server."
    40         return -code error "incompatible MySQL installation"
    41     }
     21    ui_error "${name} has been replaced by ${replaced_by}; please install ${replaced_by} instead."
     22    return -code error "obsolete port"
    4223}
    4324
    44 configure.env           QTDIR=${prefix}/libexec/qt4-mac
    45 configure.args-append   ../${distname}
    46 
    47 default_variants-append    +debug
    48 
    49 post-destroot {
    50     # Place bundle icons in correct location
    51         system "mv ${destroot}${prefix}/bin/amarok.app/Contents/Resources/* ${destroot}${applications_dir}/KDE4/Amarok.app/Contents/Resources/"
    52         system "rm -rf ${destroot}${prefix}/bin"
    53 }
    54 
     25livecheck.type      none
Note: See TracChangeset for help on using the changeset viewer.