Ignore:
Timestamp:
May 30, 2014, 12:20:27 PM (5 years ago)
Author:
mojca@…
Message:

wxWidgets portgroup: add preliminary support for the future wxWidgets 3.1/3.2

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/_resources/port1.0/group/wxWidgets-1.0.tcl

    r118524 r120493  
    115115        ui_error "You shouldn't be using 'wxWidgets.use wxPerl-3.0' any longer. Switch to wxWidgets-3.0."
    116116        return -code error "invalid parameter for wxWidgets.use"
     117    # preliminary support for wxWidgets 3.1/3.2
     118    } elseif {${args} eq "wxWidgets-3.2"} {
     119        wxWidgets.name      "wxWidgets"
     120        wxWidgets.version   "3.1"
     121        wxWidgets.port      "wxWidgets-3.2-devel"
     122        if {${os.major} < 9} {
     123            pre-fetch {
     124                ui_error "${wxWidgets.port} requires Mac OS X 10.5 or later."
     125                return -code error "incompatible Mac OS X version"
     126            }
     127        }
    117128    } else {
    118129        # throw an error
Note: See TracChangeset for help on using the changeset viewer.