Changeset 122791


Ignore:
Timestamp:
Jul 29, 2014, 10:53:30 PM (5 years ago)
Author:
mojca@…
Message:

wxWidgets-1.0.tcl: add wxWidgets-3.0-libcxx to allow building of C++11 apps on pre-10.9

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/_resources/port1.0/group/wxWidgets-1.0.tcl

    r120495 r122791  
    100100            }
    101101        }
     102    # ugly workaround to allow some C++11-only applications to be built on < 10.9
     103    } elseif {${args} eq "wxWidgets-3.0-libcxx"} {
     104        wxWidgets.name      "wxWidgets"
     105        wxWidgets.version   "3.0-libcxx"
     106        wxWidgets.port      "wxWidgets-3.0-libcxx"
     107        if {${os.major} < 9} {
     108            pre-fetch {
     109                ui_error "${wxWidgets.port} requires Mac OS X 10.5 or later."
     110                return -code error "incompatible Mac OS X version"
     111            }
     112        }
    102113    } elseif {${args} eq "wxPython-3.0"} {
    103114        wxWidgets.name      "wxPython"
Note: See TracChangeset for help on using the changeset viewer.