Changeset 125868


Ignore:
Timestamp:
Sep 28, 2014, 3:21:03 PM (6 years ago)
Author:
nicos@…
Message:

klibido: make port obsolete (based on kde3, not developed since 2006)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/news/klibido/Portfile

    r111868 r125868  
    11# $Id$
    22
     3#Port made obsolete 2014/09/28
    34PortSystem      1.0
    45
    56name            klibido
    67version         0.2.5
    7 platforms       darwin
    8 categories      news
    9 license         GPL-2+
    10 maintainers     nomaintainer
    11 description     KDE Linux Binaries Downloader
     8revision        1
    129
    13 long_description \
    14     KLibido is a KDE usenet news grabber for Linux.
     10platforms        darwin
     11maintainers      nomaintainer
     12supported_archs  noarch
     13description      this port is only a stub and has been made obsolete
     14default long_description ${description}
    1515
    16 homepage        http://klibido.sourceforge.net/
    17 master_sites    sourceforge
     16homepage        http://www.macports.org/
    1817
    19 checksums       md5     e343338541a3ff3f2983023ccc922af0 \
    20                 sha1    ff6abf45ee7ba8e9b02aeb4eea9ead4049523cae \
    21                 rmd160  cf1dd3acb4bf30343489ae1dcd3034ec6e3a94c3
     18archive_sites
     19distfiles
    2220
    23 set db_version  46
     21pre-configure {
     22    ui_error "KDE3 is considered obsolete, and is being replaced by KDE4. Consequently, ${subport} has been made obsolete"
     23    return -code error "obsolete port"
     24}
    2425
    25 depends_lib     port:kdelibs3 \
    26                 port:uudeview \
    27                 port:db${db_version}
    28 
    29 configure.args  --with-extra-includes=${prefix}/include:${prefix}/include/db${db_version} \
    30                 --with-extra-libs=${prefix}/share/lib:${prefix}/lib/db${db_version} \
    31                 --with-qt-dir=${prefix}/lib/qt3 \
    32                 --without-arts
    33 
    34 use_parallel_build  yes
    35 
    36 platform darwin 9 {
    37     # http://developer.apple.com/qa/qa2007/qa1567.html
    38     configure.ldflags-append -dylib_file /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib:/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib
    39 }
     26livecheck.type  none
Note: See TracChangeset for help on using the changeset viewer.