Changeset 126632


Ignore:
Timestamp:
Oct 13, 2014, 12:01:16 AM (5 years ago)
Author:
devans@…
Message:

glom: update to version 1.28.0, locale issues apparently only effect 10.8 and earlier.

Location:
trunk/dports/gnome/glom
Files:
3 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/gnome/glom

  • trunk/dports/gnome/glom/Portfile

    r123594 r126632  
    66
    77name            glom
    8 version         1.26.0
     8version         1.28.0
    99set branch      [join [lrange [split ${version} .] 0 1] .]
    1010license         GPL-2
     
    2121use_xz          yes
    2222
    23 checksums       rmd160  3f48af233fba992dbd86a99dc276d20d631a9a82 \
    24                 sha256  f53a2d46f766d4e50b1cde0edc4408b443f22db7662f47dd80f7b1a545050024
     23checksums       rmd160  dd2ed515360b72d9a173e7fe448549149fc098aa \
     24                sha256  bac4c97cdcca57c8eb1fb41263a7c5de4af84c6a266802f25fee338cf1b9081b
    2525
    2626depends_build   port:pkgconfig \
     27                port:autoconf \
     28                port:automake \
     29                port:libtool \
    2730                port:intltool \
    2831                port:itstool \
     
    5962require_active_variants libgda5 postgresql93
    6063
    61 # update macros/intltool.m4 and autoreconf
     64# use autogen.sh to update macros/intltool.m4 and reconfigure
    6265
    63 pre-configure {
    64     copy -force ${prefix}/share/aclocal/intltool.m4 ${worksrcpath}/macros
    65 }
    66 
    67 use_autoreconf  yes
    68 autoreconf.args -fvi
     66configure.cmd   ./autogen.sh
    6967
    7068set python.branch   2.7
     
    9492}
    9593
     94# locale issues apparently only effect OS X 10.8 and earlier.
     95
     96if {${os.major} < 12} {
     97
    9698notes "
    9799To work around known locale issues, set LANG=C when starting glom
     
    99101"
    100102
     103}
     104
    101105livecheck.type gnome
  • trunk/dports/gnome/glom/files/patch-configure.ac.diff

    r121763 r126632  
    1 --- configure.ac.orig   2014-03-06 07:48:22.000000000 -0800
    2 +++ configure.ac        2014-04-11 01:13:02.000000000 -0700
    3 @@ -63,8 +63,8 @@
    4  # i18n
    5  IT_PROG_INTLTOOL([0.35])
    6  
    7 -AM_GNU_GETTEXT([external])
    8 -AM_GNU_GETTEXT_VERSION([0.17])
    9 +#AM_GNU_GETTEXT([external])
    10 +#AM_GNU_GETTEXT_VERSION([0.17])
    11  
    12  AC_SUBST([GETTEXT_PACKAGE], [glom])
    13  AC_DEFINE([GETTEXT_PACKAGE], [PACKAGE_TARNAME], [Define to the gettext package name.])
     1--- configure.ac.orig   2014-07-07 07:47:09.000000000 -0700
     2+++ configure.ac        2014-07-07 10:36:59.000000000 -0700
    143@@ -157,7 +157,10 @@
    154 
    165 
    176 # Libraries used by libglom:
    18 -REQUIRED_LIBGLOM_LIBS='giomm-2.4 >= 2.32.0 libxml++-2.6 >= 2.23.1 libxslt >= 1.1.10 pygobject-3.0 >= 2.29.0 libgdamm-5.0 >= 4.99.6 libgda-5.0 >= 5.2.1 libgda-postgres-5.0 libgda-postgres-5.0 libgda-mysql-5.0 libarchive >= 3.0'
    19 +REQUIRED_LIBGLOM_LIBS='giomm-2.4 >= 2.32.0 libxml++-2.6 >= 2.23.1 libxslt >= 1.1.10 pygobject-3.0 >= 2.29.0 libgdamm-5.0 >= 4.99.6 libgda-5.0 >= 5.2.1 libgda-postgres-5.0 libgda-postgres-5.0 libarchive >= 3.0'
     7-REQUIRED_LIBGLOM_LIBS='giomm-2.4 >= 2.32.0 libxml++-2.6 >= 2.23.1 libxslt >= 1.1.10 pygobject-3.0 >= 2.29.0 libgdamm-5.0 >= 4.99.8 libgda-5.0 >= 5.2.1 libgda-postgres-5.0 libgda-postgres-5.0 libgda-mysql-5.0 libarchive >= 3.0'
     8+REQUIRED_LIBGLOM_LIBS='giomm-2.4 >= 2.32.0 libxml++-2.6 >= 2.23.1 libxslt >= 1.1.10 pygobject-3.0 >= 2.29.0 libgdamm-5.0 >= 4.99.8 libgda-5.0 >= 5.2.1 libgda-postgres-5.0 libgda-postgres-5.0 libarchive >= 3.0'
    209+
    2110+AS_IF([test "x$glom_enable_mysql" = xyes],
     
    2413 AS_IF([test "x$glom_host_win32" != xyes],
    2514       [REQUIRED_LIBGLOM_LIBS="$REQUIRED_LIBGLOM_LIBS libepc-1.0 >= 0.4.0"])
    26 @@ -224,6 +227,17 @@
     15@@ -230,6 +233,17 @@
    2716 # so we can use pyexec_LTLIBRARIES in the .am files:
    2817 AM_PATH_PYTHON
Note: See TracChangeset for help on using the changeset viewer.