Ignore:
Timestamp:
Oct 17, 2014, 9:38:40 PM (5 years ago)
Author:
ryandesign@…
Message:

php: update php56 to 5.6.2; update php55 to 5.5.18; update php54 to 5.4.34 (#45417); remove suhosin variant from these versions since there's no evidence it will ever be made compatible

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/lang/php/Portfile

    r126448 r126935  
    7676    5.4 {
    7777        epoch           1
    78         version         5.4.33
     78        version         5.4.34
    7979        use_bzip2       yes
    80         set suhosin_available       no
    81         checksums       ${distname}${extract.suffix} \
    82                         md5     c6878bb1cdb46bfc1e1a5cd67a024737 \
    83                         rmd160  405bb299dd59ffb683f5ab3a30a8aef0116ad6bf \
    84                         sha256  1a75b2d0835e74b8886cd3980d9598a0e06691441bb7f91d19b74c2278e40bb5
     80        checksums       md5     1afe3a10cefec9618acb785ef5064bf9 \
     81                        rmd160  6909d0e3c4bf9567faf4b5bf87004b08197c98ad \
     82                        sha256  57d4ea10f0c18b096a7c8fd0a98dcbe40c8f4dc94453fd3ca0a10e35fb2f8234
    8583    }
    8684    5.5 {
    8785        epoch           2
    88         version         5.5.17
     86        version         5.5.18
    8987        use_xz          yes
    90         set suhosin_available       no
    91         checksums       ${distname}${extract.suffix} \
    92                         md5     e5f25dae73004658533ee7701a527bd0 \
    93                         rmd160  0ab98dc5aa9529526381d0300dd25aac1da18c75 \
    94                         sha256  382b2a1cfbf67ca9e30171c9c49bfe260d5e458e07850d4b036e8430e1829093
     88        checksums       md5     3984f32985842afebe5795457e26931f \
     89                        rmd160  b63ea406a5aa8da78bfa3c4e9ee24b2cad771529 \
     90                        sha256  ccfbf6af18d1e56145867454dcbc75d90512f40ee9d3e57fdc6cb5fe3fc9726e
    9591    }
    9692    5.6 {
    9793        epoch           2
    98         version         5.6.1
     94        version         5.6.2
    9995        use_xz          yes
    100         set suhosin_available       no
    101         checksums       ${distname}${extract.suffix} \
    102                         md5     d34002f90a7049282ec663adcac7ba9e \
    103                         rmd160  9d65bedec3835fc707e46e49c567931b316cdc84 \
    104                         sha256  57640a700364949292da06e55423f162428a864451d05751a8829ae04d65745e
     96        checksums       md5     c976f54d429a0e5214659b0098e44e37 \
     97                        rmd160  542dea18fca30607df0deff1461e8821282047c1 \
     98                        sha256  9be1322d33520fb2164282fb0fcdc212f66ffedcd912bff60955d5696454fe39
    10599    }
    106100}
     
    113107#         master_sites    http://downloads.php.net/tyrael/
    114108#         use_xz          yes
    115 #         set suhosin_available       no
    116109#         checksums       ${distname}${extract.suffix} \
    117110#                         md5     0123456789 \
     
    197190                        --disable-fpm
    198191
    199     if {[vercmp ${php.branch} 5.4] >= 0} {
     192    if {[vercmp ${branch} 5.4] >= 0} {
    200193        # https://bugs.php.net/bug.php?id=68114
    201194        configure.args-append ac_cv_decimal_fp_supported=no
     
    215208    }
    216209   
     210    if {[vercmp ${branch} 5.3] <= 0} {
    217211    variant suhosin description {Add Suhosin patch} {
    218212        pre-fetch {
     
    238232        }
    239233    }
     234    }
    240235   
    241236    if {${subport} ne ${php}} {
     
    296291    }
    297292   
    298     if {[vercmp ${php.branch} 5.4] < 0} {
     293    if {[vercmp ${branch} 5.4] < 0} {
    299294        notes-append "
    300 PHP ${php.branch} has reached end-of-life. Please upgrade to PHP 5.4 or newer. The newest stable version is ${php.latest_stable_branch}.
     295PHP ${branch} has reached end-of-life. Please upgrade to PHP 5.4 or newer. The newest stable version is ${php.latest_stable_branch}.
    301296
    302297To learn how to update your code, please read the following guides:
     
    310305    }
    311306   
    312     if {[vercmp ${php.branch} ${php.latest_stable_branch}] > 0} {
     307    if {[vercmp ${branch} ${php.latest_stable_branch}] > 0} {
    313308        notes-append "${php} @${version}_${revision} is a development preview—do not use it in production!\n\n\n"
    314309    }
Note: See TracChangeset for help on using the changeset viewer.