Changeset 127517 for trunk/dports/gnome


Ignore:
Timestamp:
Oct 29, 2014, 2:40:14 AM (5 years ago)
Author:
devans@…
Message:

empathy: update to version 3.12.7, drop python variants and build with python27, drop +location as default variant due to broken geoclue2, allow parallel build.

Location:
trunk/dports/gnome/empathy
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/gnome/empathy

  • trunk/dports/gnome/empathy/Portfile

    r127180 r127517  
    55
    66name                empathy
    7 version             3.12.6
     7version             3.12.7
    88license             GPL-2+ LGPL-2.1+ GFDL-1.3+ Attribution-ShareAlike-3.0
    99set branch          [join [lrange [split ${version} .] 0 1] .]
     
    2020use_xz              yes
    2121
    22 checksums           rmd160  8b003613779cdfe4dd9f1075c89c29c5ddc100e6 \
    23                     sha256  bf52e0c0af6179925dbf37b406d42d4a5f5e60131052a7f6a7e1822891fa0f6f
     22checksums           rmd160  74d58c3a1f769a872ad0cadb707d843670a853e4 \
     23                    sha256  abcc6e325474d158ba21dfc864183617cf832c3570ccefe9e32f275b94452794
    2424
    2525depends_build       port:pkgconfig \
     
    3131                    port:automake \
    3232                    port:libtool \
    33                     port:libxslt
     33                    port:libxslt \
     34                    port:python27
    3435
    3536depends_lib         port:desktop-file-utils \
    36                     port:gnome-icon-theme \
    37                     port:gnome-icon-theme-symbolic \
    3837                    port:gtk3 \
    3938                    port:dbus-glib \
     
    7776
    7877configure.cmd       ./autogen.sh
     78configure.python    ${prefix}/bin/python2.7
    7979
    8080configure.args      --x-includes=${prefix}/include \
     
    9696                    --disable-Werror
    9797
    98 use_parallel_build  no
     98#
     99# folks is not universal
     100#
     101
     102universal_variant   no
    99103
    100104variant map description {Enable map view} {
     
    108112}
    109113
    110 variant location description {Enable location awareness using geoclue} {
     114variant location description {Enable location awareness using geoclue2 (broken)} {
    111115    depends_lib-append      port:geoclue2
    112116    configure.args-replace  --enable-location=no --enable-location=yes
     
    119123}
    120124
    121 default_variants +map +geocode +goa +location
    122 
    123 #
    124 # folks is not universal
    125 #
    126 
    127 universal_variant no
    128 
    129 variant python26 conflicts python27 description {Build using Python 2.6} {
    130     configure.python          ${prefix}/bin/python2.6
    131     depends_build-append      port:python26
    132 }
    133 
    134 variant python27 conflicts python26 description {Build using Python 2.7} {
    135     configure.python          ${prefix}/bin/python2.7
    136     depends_build-append      port:python27
    137 }
    138 
    139 if {![variant_isset python26]} {
    140     default_variants +python27
    141 }
     125default_variants    +map +geocode +goa
    142126
    143127post-activate {
Note: See TracChangeset for help on using the changeset viewer.