Changeset 12754


Ignore:
Timestamp:
Jun 20, 2005, 6:07:25 PM (14 years ago)
Author:
mij
Message:
  • Fix build
  • Update to version 1.5.10
  • Remove variants for GTK1 & GTK2 and use GTK2 by default since GTK1 is pretty much dead and should be removed from the tree eventually.

Bug:
Submitted by:
Reviewed by:
Approved by:
Obtained from:

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/games/dopewars/Portfile

    r11593 r12754  
    1 # $Id: Portfile,v 1.15 2005/04/04 10:08:36 jkh Exp $
     1# $Id: Portfile,v 1.16 2005/06/20 18:07:25 mij Exp $
    22
    33PortSystem 1.0
    44name            dopewars
    5 version         1.5.9
    6 revision        1
     5version         1.5.10
    76categories      games
    87maintainers     mij@opendarwin.org
     
    1817master_sites    sourceforge
    1918
    20 checksums       md5 77cdbc59e7550cfda7dfb7f6b7a01050
     19checksums       md5 99f07eac91f1f272f43d16ba81205c66
    2120
     21depends_lib     lib:libgtk.2:gtk2 lib:libesd.0:esound
    2222
    23 depends_lib     lib:libintl.3:gettext lib:libesd.0:esound
     23post-patch      { reinplace "s| \$\(dopewars_DEPENDENCIES\)||g" ${worksrcpath}/src/Makefile.in
     24                  reinplace "s|need_relink=yes|need_relink=no|g" ${worksrcpath}/ltmain.sh
     25                  reinplace "s|LIBADD =|LIBADD = -module -avoid-version|g" ${worksrcpath}/src/plugins/Makefile.in }
    2426
    25 configure.args  --enable-nls --enable-networking --without-sdl \
    26                 --disable-gui-client --enable-curses-client \
    27                 --disable-glib2 --with-libiconv-prefix=${prefix}
     27configure.env   LDFLAGS="-L${prefix}/lib" \
     28                CPPFLAGS="-I${prefix}/include"
    2829
    29 default_variants +gtk2
     30configure.args  --enable-nls --enable-networking --without-sdl --with-pic \
     31                --enable-gui-client --enable-plugins --enable-shared \
     32                --enable-static --mandir=${prefix}/share/man
    3033
    3134platform darwin 6 { depends_lib-append lib:libdl:dlcompat }
    32 
    33 variant gtk1    { depends_lib-append lib:libgtk.1:gtk1
    34                   configure.args { --enable-nls --enable-networking \
    35                                    --without-sdl --enable-gui-client \
    36                                    --disable-glib2 \
    37                                    --with-libiconv-prefix=${prefix} } }
    38 
    39 variant gtk2    { depends_lib-append lib:libgtk.2:gtk2
    40                   configure.args { --enable-nls --enable-networking \
    41                                    --without-sdl --enable-gui-client \
    42                                    --with-libiconv-prefix=${prefix} } }
Note: See TracChangeset for help on using the changeset viewer.