Changeset 127709


Ignore:
Timestamp:
Nov 1, 2014, 2:51:37 PM (5 years ago)
Author:
devans@…
Message:

vte-gtk2-compat: drop +python26 variant and legacy +without_python variant, default to optional +python27 variant.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/gnome/vte-gtk2-compat/Portfile

    r122211 r127709  
    77set gname       vte
    88version         0.28.2
     9revision        1
    910set branch      [join [lrange [split $version .] 0 1] .]
    1011maintainers     devans openmaintainer
     
    4849configure.cflags-append -fstrict-aliasing
    4950
    50 # default to python27 bindings
    51 if {![variant_isset python27] && ![variant_isset python26] && ![variant_isset without_python]} {
    52     default_variants +python27
    53 }
    54 
    55 variant python27 conflicts python26 \
    56 description {Build Bindings for Python 2.7} {
     51variant python27 description {Build Python bindings using Python 2.7} {
    5752    configure.args-delete --disable-python
    5853    set python_prefix ${frameworks_dir}/Python.framework/Versions/2.7
     
    6358}
    6459
    65 variant python26 conflicts python27 \
    66 description {Build Bindings for Python 2.6} {
    67     configure.args-delete --disable-python
    68     set python_prefix ${frameworks_dir}/Python.framework/Versions/2.6
    69     depends_lib-append port:py26-pygtk
    70     configure.python ${prefix}/bin/python2.6
    71     configure.pkg_config_path   ${python_prefix}/lib/pkgconfig
    72     configure.env               PATH=${python_prefix}/bin:$env(PATH)
    73 }
     60# default to optional python27 bindings
    7461
    75 variant without_python description {Disable Python support (deprecated, use -pythonXX instead)} {
    76     default_variants -python27 -python26
    77 }
     62default_variants +python27
    7863
    7964# rename gnome-pty-helper to avoid a conflict with port vte
Note: See TracChangeset for help on using the changeset viewer.