Changeset 129787


Ignore:
Timestamp:
Dec 20, 2014, 7:53:31 PM (5 years ago)
Author:
jwa@…
Message:

pgAdmin3: version bump to 1.20.0, postgresql94 the new default

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/aqua/pgAdmin3/Portfile

    r121085 r129787  
    66
    77name                pgAdmin3
    8 version             1.18.1
    9 revision            1
     8version             1.20.0
    109
    1110categories          aqua
     
    2827distname            pgadmin3-${version}
    2928
    30 checksums           rmd160  03a55056c98d7c1458019a505078c512f425f7e0 \
    31                     sha256  27ac3e296a6ca3da9da8ee22ed98eabfe1377be507877ffc26048fc2a9c6cbc0
     29checksums           rmd160  3f2902b68a915d88bc93c10b897f4c163459b03e \
     30                    sha256  0773d7826a9c7a998c4872e9b00b998e0bbb10448984d66853420c95fa626b8c
    3231
    3332wxWidgets.use       wxWidgets-3.0
     
    5453}
    5554
    56 #destroot.violate_mtree yes
     55destroot.violate_mtree yes
    5756destroot {
    5857    xinstall -d -m 0755 ${destroot}${applications_dir}
     
    6059}
    6160
    62 variant postgresql84 conflicts postgresql90 postgresql91 postgresql92 postgresql93 \
     61variant postgresql84 conflicts postgresql90 postgresql91 postgresql92 postgresql93 postgresql94 \
    6362    description {support for PostgreSQL 8.4.x} {
    6463    depends_lib-append      port:postgresql84
     
    6665}
    6766
    68 variant postgresql90 conflicts postgresql84 postgresql91 postgresql92 postgresql93 \
     67variant postgresql90 conflicts postgresql84 postgresql91 postgresql92 postgresql93 postgresql94 \
    6968    description {support for PostgreSQL 9.0.x} {
    7069    depends_lib-append      port:postgresql90
     
    7271}
    7372
    74 variant postgresql91 conflicts postgresql84 postgresql90 postgresql92 postgresql93 \
     73variant postgresql91 conflicts postgresql84 postgresql90 postgresql92 postgresql93 postgresql94 \
    7574    description {support for PostgreSQL 9.1.x} {
    7675    depends_lib-append      port:postgresql91
     
    7877}
    7978
    80 variant postgresql92 conflicts postgresql84 postgresql90 postgresql91 postgresql93 \
     79variant postgresql92 conflicts postgresql84 postgresql90 postgresql91 postgresql93 postgresql94 \
    8180    description {support for PostgreSQL 9.2.x} {
    8281    depends_lib-append      port:postgresql92
     
    8483}
    8584
    86 variant postgresql93 conflicts postgresql84 postgresql90 postgresql91 postgresql92 \
     85variant postgresql93 conflicts postgresql84 postgresql90 postgresql91 postgresql92 postgresql94 \
    8786    description {support for PostgreSQL 9.3.x} {
    8887    depends_lib-append      port:postgresql93
     
    9089}
    9190
    92 if {![variant_isset postgresql84] && ![variant_isset postgresql90] && ![variant_isset postgresql91] && ![variant_isset postgresql92]  && ![variant_isset postgresql93]} {
    93     default_variants        +postgresql93
     91variant postgresql94 conflicts postgresql84 postgresql90 postgresql91 postgresql92 postgresql93 \
     92    description {support for PostgreSQL 9.4.x} {
     93    depends_lib-append      port:postgresql94
     94    configure.args-append   --with-pgsql=${prefix}/lib/postgresql94
     95}
     96
     97if {![variant_isset postgresql84] && ![variant_isset postgresql90] && ![variant_isset postgresql91] && ![variant_isset postgresql92]  && ![variant_isset postgresql93] && ![variant_isset postgresql94]} {
     98    default_variants        +postgresql94
    9499}
    95100
     
    98103}
    99104
    100 variant with_postgresql83 requires postgresql83 description {Legacy compatibility variant} {}
    101105variant with_postgresql84 requires postgresql84 description {Legacy compatibility variant} {}
    102106variant with_postgresql90 requires postgresql90 description {Legacy compatibility variant} {}
Note: See TracChangeset for help on using the changeset viewer.