Ignore:
Timestamp:
Jan 7, 2015, 9:26:04 PM (5 years ago)
Author:
devans@…
Message:

ffmpeg: update to version 2.5.2, if +x11 asserted enable X11 frame grabbing using XCB although, through no fault of its own, in doesn't work with XQuartz, use avfoundation indev instead (#46281).

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/multimedia/ffmpeg/Portfile

    r129854 r131259  
    1111conflicts       ffmpeg-devel
    1212epoch           1
    13 version         2.5.1
     13version         2.5.2
    1414license         LGPL-2.1+
    1515categories      multimedia
     
    5353use_bzip2       yes
    5454
    55 checksums       rmd160  0ff92a2408872f9ce95614ac889fa57c843f926a \
    56                 sha256  03cf50b2f9109548e466f144c960b37031ffc1b9fab96382b4b26b7607c7ef52
     55checksums       rmd160  22d153c3928e6dd825871ef0ece64d3ca131ae28 \
     56                sha256  9edf17e7c280cbcfca4bc4219b1c22f760a61ec6a3f39ef26e3e2ad4cd24465e
    5757
    5858depends_build   port:pkgconfig \
     
    206206}
    207207
    208 # this dummy variant is used to mark whether ffmpeg is built with
    209 # libsdl +x11 and hence has a binary dependency on xorg-libX11
    210 # or libsdl -x11 and does not
    211 
    212 variant x11 {}
     208variant x11 {
     209#
     210# enable x11grab_xcb input device
     211#
     212    depends_lib-append      port:xorg-libxcb \
     213                            port:xorg-libXext \
     214                            port:xorg-libXfixes
     215
     216    configure.args-delete   --disable-libxcb \
     217                            --disable-libxcb-shm \
     218                            --disable-libxcb-xfixes \
     219}
     220
    213221default_variants +x11
    214222
Note: See TracChangeset for help on using the changeset viewer.