Changeset 132977


Ignore:
Timestamp:
Feb 16, 2015, 1:03:58 PM (5 years ago)
Author:
devans@…
Message:

p5-plack-middleware-methodoverride: update to version 0.12, dependencies, no longer uses module build.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/perl/p5-plack-middleware-methodoverride/Portfile

    r131655 r132977  
    66
    77perl5.branches      5.16 5.18 5.20
    8 perl5.setup         Plack-Middleware-MethodOverride 0.11
     8perl5.setup         Plack-Middleware-MethodOverride 0.12
    99
    1010platforms           darwin
     
    1212license             {Artistic-1 GPL}
    1313
    14 supported_archs     noarch
    15 
    1614description         Override REST methods to Plack apps via POST
    1715long_description    ${description}
    1816
    19 checksums           rmd160  62808868ab5799ac99880d73f3822c1aaf8bffc7 \
    20                     sha256  bf8881ee525f0c62e434f9cadc5f56865bdbeecefc8c738125476f124f6f68c1
     17checksums           rmd160  3a07b5c631278f2ea7390170ef587ada1abc5098 \
     18                    sha256  df81c5fec735520ef437c92edff1cf1caafd2e9ecf4c16d93d714fdea6f3b6b7
    2119
    2220if {${perl5.major} != ""} {
     21    depends_build-append \
     22                    port:p${perl5.major}-uri
     23
    2324    depends_lib-append \
    24                     port:p${perl5.major}-plack \
    25                     port:p${perl5.major}-uri
     25                    port:p${perl5.major}-plack
     26
     27    supported_archs noarch
    2628}
    27 
    28 perl5.use_module_build
Note: See TracChangeset for help on using the changeset viewer.