Ignore:
Timestamp:
Mar 15, 2015, 6:27:27 PM (5 years ago)
Author:
ryandesign@…
Message:

doxygen: always use python 2.7, not just in the doc variant; fixes build on Tiger and Leopard (#44638)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/textproc/doxygen/Portfile

    r133357 r133906  
    4040
    4141depends_build-append    bin:perl:perl5 \
     42                        bin:python2.7:python27 \
    4243                        port:flex \
    4344                        port:bison
    44 license_noconflict      perl5
     45license_noconflict      perl5 python27
    4546
    4647depends_lib             port:libpng \
     
    115116                        --disable-dependency-tracking
    116117configure.pre_args      --prefix ${prefix}
    117 configure.args          --make ${build.cmd}
     118configure.args          --make ${build.cmd} \
     119                        --python python2.7
    118120
    119121build.target            all
     
    128130
    129131    configure.args-append   --docdir ${prefix}/share/doc \
    130                             --dot ${prefix}/bin/dot \
    131                             --python python2.7
     132                            --dot ${prefix}/bin/dot
    132133
    133     depends_build-append    path:bin/dot:graphviz \
    134                             bin:python2.7:python27
     134    depends_build-append    path:bin/dot:graphviz
    135135    build.target-append     pdf
    136136    use_parallel_build      no
Note: See TracChangeset for help on using the changeset viewer.