Changeset 133944


Ignore:
Timestamp:
Mar 16, 2015, 12:41:51 AM (4 years ago)
Author:
khindenburg@…
Message:

py-openslide: add python 34; add patch to find correct library maintainer #46256

Location:
trunk/dports/python/py-openslide
Files:
2 added
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/python/py-openslide/Portfile

    r120150 r133944  
    88github.setup        openslide openslide-python 1.0.1 v
    99name                py-openslide
     10revision            1
    1011categories-append   graphics
    1112platforms           darwin
     
    1415maintainers         backtick.net:bgilbert
    1516
    16 # We can support 33 as soon as py-flask does.
    17 python.versions     26 27
     17# Upstream supports 2.6 and 3.3, but python/py-werkzeug doesn't.
     18# For those Python versions, we could omit support entirely, or omit the
     19# example scripts.  For consistency, we do the former.
     20python.versions     27 34
    1821python.default_version  27
    1922
     
    5255    build.target-append build_sphinx
    5356
     57    patchfiles          patch-disable-find_library-fallback.diff
     58
     59    post-patch {
     60        reinplace "s|@@PREFIX@@|${prefix}|g" \
     61            ${worksrcpath}/openslide/lowlevel.py
     62    }
     63
    5464    post-destroot {
    5565        set docdir ${prefix}/share/doc/${subport}
Note: See TracChangeset for help on using the changeset viewer.