Changeset 134429


Ignore:
Timestamp:
Mar 25, 2015, 3:26:48 PM (4 years ago)
Author:
devans@…
Message:

epiphany: reconfigure using autogen.sh for intltool 0.51 compatibility, remove GTK_DISABLE_DEPRECATED from DEPRECATION_FLAGS to fix build.

Location:
trunk/dports/gnome/epiphany
Files:
1 added
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/gnome/epiphany/Portfile

    r121198 r134429  
    2828depends_build   port:pkgconfig \
    2929                port:intltool \
    30                 port:gnome-common
     30                port:gnome-common \
     31                port:autoconf \
     32                port:automake \
     33                port:libtool
    3134
    3235depends_lib     port:desktop-file-utils \
     
    6164patchfiles      patch-configure.ac.diff
    6265
    63 # update m4/intltool.m4 and autoreconf
     66# reconfigure using autogen.sh for intltool 0.51 compatibility
    6467
    65 pre-configure {
    66     copy -force ${prefix}/share/aclocal/intltool.m4 ${worksrcpath}/m4
    67     reinplace "s|--rpath=|-rpath |g" ${worksrcpath}/configure.ac
     68post-patch {
     69    xinstall -m 755 ${filespath}/autogen.sh ${worksrcpath}
    6870}
    6971
    70 use_autoreconf      yes
    71 autoreconf.args     -fvi
     72configure.cmd       ./autogen.sh
    7273
    7374configure.cflags-append -Wno-format-nonliteral
  • trunk/dports/gnome/epiphany/files/patch-configure.ac.diff

    r118114 r134429  
    1 --- configure.ac.orig   2013-05-31 03:28:55.000000000 -0700
    2 +++ configure.ac        2014-02-21 20:21:48.000000000 -0800
     1--- configure.ac.orig   2015-03-25 08:15:37.000000000 -0700
     2+++ configure.ac        2015-03-25 08:16:05.000000000 -0700
     3@@ -73,7 +73,7 @@
     4 if test "$enable_maintainer_mode" = "yes"; then
     5        AC_DEFINE([MAINTAINER_MODE],[1],[Define to enable 'maintainer-only' behaviour])
     6        enable_debug=yes
     7-       DEPRECATION_FLAGS="-DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED -DGNOME_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGSEAL_ENABLE"
     8+       DEPRECATION_FLAGS="-DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED -DGNOME_DISABLE_DEPRECATED -DGSEAL_ENABLE"
     9 fi
     10 
     11 GLIB_REQUIRED=2.35.6
    312@@ -90,7 +90,7 @@
    413 AVAHI_REQUIRED=0.6.22
Note: See TracChangeset for help on using the changeset viewer.