Ignore:
Timestamp:
Aug 10, 2005, 9:19:33 PM (15 years ago)
Author:
pguyot (Paul Guyot)
Message:

Support for libcurl versions that do not have curl_easy_strerror.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/base/configure.ac

    r13443 r13457  
    7171
    7272# Check for Tcl public headers
    73 dnl XXX hardwire CYGPATH (CYGPATH must be set for SC_PUBLIC_TCL_HEADERS)
     73dnl XXX  hardwire CYGPATH (CYGPATH must be set for SC_PUBLIC_TCL_HEADERS)
    7474CYGPATH=echo
    7575SC_PUBLIC_TCL_HEADERS
     
    8686## libcurl
    8787OD_LIBCURL_FLAGS
     88
     89# Do we have curl_easy_strerror?
     90AH_TEMPLATE([HAVE_CURL_EASY_STRERROR],
     91               [Define to 1 if you have the curl_easy_strerror function.])
     92AC_CHECK_LIB([curl], [curl_easy_strerror],
     93        [AC_DEFINE([HAVE_CURL_EASY_STRERROR])],[],
     94        [$LDFLAGS_LIBCURL])
    8895
    8996# Determine if we need to install some bundled packages
Note: See TracChangeset for help on using the changeset viewer.