Changeset 134894


Ignore:
Timestamp:
Apr 10, 2015, 10:10:35 AM (5 years ago)
Author:
jeremyhu@…
Message:

llvm-3.7: Drop dependency on isl and gmp for polly builds since it now includes an internal version of isl and gmp

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/lang/llvm-3.7/Portfile

    r134736 r134894  
    299299
    300300if {${subport} eq "llvm-${llvm_version}"} {
    301     variant polly description {Provide the polly polyhedral optimizer} {
    302         depends_lib-append      port:gmp
    303         if {${worksrcdir} eq "trunk"} {
    304             # Polly likes using bleeding-edge isl.
    305             depends_lib-append  port:isl-devel
    306         } else {
    307             depends_lib-append  path:lib/pkgconfig/isl.pc:isl
    308         }
    309     }
     301    variant polly description {Provide the polly polyhedral optimizer} {}
    310302
    311303    # Unless upstream reverts to their old OCaml detection mechanism,
Note: See TracChangeset for help on using the changeset viewer.