Changeset 135644 for trunk/dports/cross


Ignore:
Timestamp:
Apr 28, 2015, 7:42:18 PM (4 years ago)
Author:
snc@…
Message:

openocd: update to 0.8.0, #44855

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/cross/openocd/Portfile

    r112971 r135644  
    55
    66name                openocd
    7 version             0.7.0
     7version             0.8.0
    88categories          cross devel
    99license             GPL
     
    2121
    2222use_bzip2           yes
    23 checksums           md5     8977a26a4e3a529e1c4fcc0df587a6a4 \
    24                     sha1    40fa518af4fae273f24478249fc03aa6fcce9176 \
    25                     rmd160  f232ce21a054ad56a80f0605fe8b22b6712434f0 \
    26                     sha256  52237b786530c8460b221556c26fa4779f668b7dcb83ff14b8c5eb2050f38e63
     23checksums           sha1    10bf9eeb54e03083cb1a101785b2d69fbdf18f31 \
     24                    rmd160  812755bb51ccf6bb11e4b6aac6dd1c0c674c43b7 \
     25                    sha256  5b076c324400ef0198ce6e21616e17f7a1a12f749362821ce0b03ec62c3cd32f
    2726
    2827configure.args-append  --disable-werror --enable-maintainer-mode
    2928
    30 default_variants +ft2232
     29depends_build-append    port:pkgconfig
     30
     31default_variants +ftdi
    3132
    3233variant dummy description {Enable building the dummy port driver} {
     
    3839}
    3940
    40 variant ft2232 conflicts ft2232_ftd2xx  description {Enable building support for FT2232 based devices using the libftdi driver, opensource alternate of FTD2XX} {
    41     configure.args-append --enable-ft2232_libftdi
    42         depends_lib-append  port:libftdi0 \
    43                         port:libusb-compat
     41variant ftdi conflicts ft2232_ftd2xx description {Enable building OpenOCD's built-in FTDI driver.} {
     42    configure.args-append --enable-ftdi
     43        depends_lib-append port:libusb
    4444}
    4545
     46# The ft2232 variant is deprecated, the ftdi variant is its replacement
     47variant ft2232 conflicts ft2232_ftd2xx  description {Enable building support for FT2232 based devices using the libftdi driver, opensource alternate of FTD2XX} {
     48    configure.args-append --enable-legacy-ft2232_libftdi
     49        depends_lib-append port:libftdi1
     50}
     51
     52# The ft2232_ftd2xx variant is deprecated, the ftdi variant is its replacement
    4653variant ft2232_ftd2xx conflicts ft2232  description {Enable building support for FT2232 based devices using the FTD2XX driver from ftdichip.com} {
    4754    patchfiles-append patch-ftd2xx-path.diff
    48     configure.args-append --enable-ft2232_ftd2xx
     55    use_autoreconf      yes
     56    configure.args-append --enable-legacy-ft2232_ftd2xx
    4957        depends_lib-append port:libftd2xx
    5058}
     
    5260variant usb_blaster conflicts usb_blaster_ftd2xx description {Enable building support for the Altera USB-Blaster using the libftdi driver, opensource alternate of FTD2XX} {
    5361    configure.args-append --enable-usb_blaster_libftdi
    54         depends_lib-append port:libftdi0
     62        depends_lib-append port:libftdi1
    5563}
    5664
    5765variant usb_blaster_ftd2xx conflicts usb_blaster description {Enable building support for the Altera USB-Blaster using the FTD2XX driver from ftdichip.com} {
     66    patchfiles-append patch-ftd2xx-path.diff
     67    use_autoreconf      yes
    5868    configure.args-append --enable-usb_blaster_ftd2xx
    5969        depends_lib-append port:libftd2xx
     
    94104variant presto conflicts presto_ftd2xx description {Enable building support for ASIX Presto Programmer using the libftdi driver} {
    95105    configure.args-append --enable-presto_libftdi
    96         depends_lib-append port:libftdi0
     106        depends_lib-append port:libftdi1
    97107}
    98108
Note: See TracChangeset for help on using the changeset viewer.