Ignore:
Timestamp:
Sep 19, 2015, 2:09:06 AM (5 years ago)
Author:
takeshi@…
Message:

xhyve: raise error on OS X older than Yosemite

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/emulators/xhyve/Portfile

    r140410 r140411  
    2222                    sha256 b7b96388da660b6224623a6445f61c1645123d59637023bb6e2c7fb29522619d
    2323
     24pre-fetch {
     25    if {${os.platform} eq "darwin" && (${os.major} < 14)} {
     26        ui_error "${name} is built on top of Hypervisor.framework in OS X 10.10 Yosemite and higher"
     27            return -code error "incompatible OS X version"
     28    }
     29}
     30
    2431post-patch {
    2532    reinplace "s|test/|${prefix}/share/${name}/test/|" ${worksrcpath}/${name}run.sh
Note: See TracChangeset for help on using the changeset viewer.