Changeset 142117


Ignore:
Timestamp:
Nov 4, 2015, 7:48:20 AM (4 years ago)
Author:
mojca@…
Message:

gstreamer010-gst-plugins-base: remove no_x11 no_ogg no_gnome_vfs (#39383)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/gnome/gstreamer010-gst-plugins-base/Portfile

    r132192 r142117  
    6363}
    6464
    65 # legacy variants +no_x11 +no_ogg +no_gnome_vfs may be removed after 5/2015
    66 
    67 variant no_x11 conflicts x11 description {Legacy compatibility variant} {}
    68 
    69 variant x11 conflicts no_x11 {
     65variant x11 {
    7066    depends_lib-append port:xorg-libice \
    7167                       port:xorg-libsm \
     
    7571}
    7672
    77 if {[variant_isset no_x11]} {
    78     default_variants -x11
    79 } else {
    80     default_variants +x11
    81 }
    82 
    83 variant no_ogg conflicts ogg description {Legacy compatibility variant} {}
    84 
    85 variant ogg conflicts no_ogg description {Build with support for libogg, libvorbis, libtheora} {
     73variant ogg description {Build with support for libogg, libvorbis, libtheora} {
    8674    depends_lib-append    port:libogg port:libvorbis port:libtheora
    8775    configure.args-delete --disable-ogg --disable-vorbis --disable-theora
    8876}
    8977
    90 if {[variant_isset no_ogg]} {
    91     default_variants -ogg
    92 } else {
    93     default_variants +ogg
    94 }
    95 
    9678# users of qt4-x11, which depends on gst-plugins-base but has no use for its
    97 # deeper gnome-related dependencies may wish to use this variant
    98 variant no_gnome_vfs conflicts gnome_vfs description {Legacy compatibility variant} {}
    99 
    100 variant gnome_vfs conflicts no_gnome_vfs description {Enable gnome-vfs support} {
     79# deeper gnome-related dependencies may wish to disable this variant
     80variant gnome_vfs description {Enable gnome-vfs support} {
    10181    depends_lib-append    port:gnome-vfs
    10282    configure.args-delete --disable-gnome_vfs
    103 }
    104 
    105 if {[variant_isset no_gnome_vfs]} {
    106     default_variants -gnome_vfs
    107 } else {
    108     default_variants +gnome_vfs
    10983}
    11084
     
    12599    configure.args-delete --disable-cdparanoia
    126100}
     101
     102default_variants +gnome_vfs +ogg +x11
    127103
    128104#-fgcse (from -O2) causes build failures, but -O2 -fno-gcse doesn't seem to work
Note: See TracChangeset for help on using the changeset viewer.