Changeset 143238 for trunk/dports/math


Ignore:
Timestamp:
Dec 9, 2015, 10:45:06 AM (4 years ago)
Author:
mojca@…
Message:

gnuplot: fix dependency on qt5

Location:
trunk/dports/math/gnuplot
Files:
1 added
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/math/gnuplot/Portfile

    r140960 r143238  
    99name                gnuplot
    1010version             5.0.1
    11 revision            3
     11revision            4
    1212categories          math science
    1313# the license has some inconvenient requirements that we're not meeting
     
    5454patchfiles          patch-configure.diff \
    5555                    patch-term-lua.trm.diff
     56#                   patch-src-qtterminal-qt_conversion.cpp.diff
    5657
    5758configure.args      --with-caca=${prefix} \
     
    110111
    111112variant qt5 conflicts qt description "Enable qt terminal with Qt 5" {
    112     depends_lib-append          port:qt5-mac
     113    if { ${configure.cxx_stdlib} ne "libc++" } {
     114        ui_warn "Gnuplot should be compiled against libc++ if you want to use Qt 5."
     115    }
     116
     117    depends_lib-append          port:qt5
    113118    configure.env-append        "PKG_CONFIG_PATH=${prefix}/libexec/qt5-mac/lib/pkgconfig"
    114119
Note: See TracChangeset for help on using the changeset viewer.