Changeset 143283


Ignore:
Timestamp:
Dec 9, 2015, 9:34:01 PM (4 years ago)
Author:
cal@…
Message:

nginx: Update to 1.9.8, update lua module to work with 1.9.8, closes #49947

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/www/nginx/Portfile

    r142649 r143283  
    55
    66name                nginx
    7 version             1.9.7
     7version             1.9.8
    88categories          www mail
    99platforms           darwin
     
    3535distfiles           ${name}-${version}${extract.suffix}:nginx
    3636checksums           ${name}-${version}${extract.suffix} \
    37                     rmd160  96293ba41a5e37b1a0fba2479ba6b4f14ea6defe \
    38                     sha256  794bd217affdfce1c6263d9199c3961f387a2df9d57dcb42876faaf41c1748d5
     37                    rmd160  30419c256f6dfa5be74a7f0179637588d40286a2 \
     38                    sha256  36b1ec716c5735e7d37f60a421549f100c3494438f0ae173e8e869e04d408d3d
    3939
    4040depends_lib         port:pcre \
     
    345345    depends_lib-append      port:luajit
    346346    set ngx_lua_filename    lua-nginx-module
    347     set ngx_lua_version     0.9.16rc1
     347    set ngx_lua_version     0.9.19
    348348    set ngx_lua_distname    ${ngx_lua_filename}-${ngx_lua_version}
    349349    distfiles-append        v${ngx_lua_version}.tar.gz:lua_module
    350350    checksums-append        v${ngx_lua_version}.tar.gz \
    351                             rmd160  b992137a8d9b6ada437ec9016cebae123e51c4ad \
    352                             sha256  edde780f227089c41f6feab56217803c6d8347d82b0ffe99b95fd2217828595b
     351                            rmd160  e125372c1f3a1985ef70c55c2d7907ed4dc6b5fb \
     352                            sha256  2b41d4d2627fda76946f194aae6c2b4d89bb59afd792d397c6b481ee82c10eb4
    353353
    354354    configure.cflags        -I${prefix}/include/luajit-2.0/ ${configure.cflags}
     
    356356    configure.env           LUAJIT_LIB=${prefix}/lib
    357357    configure.args-append   --add-module=${workpath}/${ngx_lua_distname}
    358 
    359     pre-fetch {
    360         ui_error "The +lua variant is currently broken, because the lua module is not compatible with nginx 1.9.0."
    361         error "incompatible variant selection"
    362     }
    363358}
    364359
Note: See TracChangeset for help on using the changeset viewer.