Changeset 143421


Ignore:
Timestamp:
Dec 12, 2015, 10:14:10 AM (3 years ago)
Author:
mojca@…
Message:

mtn-browse: switch to perl5.22 using the perl5 portgroup (#48365), dependencies are needed during build

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/devel/mtn-browse/Portfile

    r123264 r143421  
    33
    44PortSystem          1.0
     5PortGroup           perl5 1.0
    56
    67name                mtn-browse
    78version             1.10
    8 set perl_version    5.16
     9perl5.branches      5.22
     10revision            1
    911categories          devel
    1012license             GPL-3+
     
    2628                    sha256  ea2683c53d688ba24f863a4c6bdffc939a745636fb7ec5174161c5f39fa03212
    2729
    28 depends_run         port:p${perl_version}-gnome2 \
    29                     port:p${perl_version}-gtk2-gladexml \
    30                     port:p${perl_version}-gtk2-sourceview \
    31                     port:p${perl_version}-libintl-perl \
    32                     port:p${perl_version}-monotone-automatestdio
     30depends_lib         port:p${perl5.major}-gnome2 \
     31                    port:p${perl5.major}-gtk2-gladexml \
     32                    port:p${perl5.major}-gtk2-sourceview \
     33                    port:p${perl5.major}-libintl-perl \
     34                    port:p${perl5.major}-monotone-automatestdio
    3335
    3436use_configure       no
    3537
    3638build {
    37     reinplace "s|/usr/bin/perl|${prefix}/bin/perl${perl_version}|g" \
     39    reinplace "s|/usr/bin/perl|${perl5.bin}|g" \
    3840        ${worksrcpath}/mtn-browse \
    3941        ${worksrcpath}/linux-installer
Note: See TracChangeset for help on using the changeset viewer.