Ignore:
Timestamp:
Jan 28, 2016, 3:13:09 PM (3 years ago)
Author:
adfernandes@…
Message:

sysutils/ansible: update to 2.0.0.2-1, updating dependencies and building docs

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/sysutils/ansible/Portfile

    r144274 r145208  
    1010categories      sysutils
    1111
    12 github.setup    ${name} ${name} 1.9.4-1 v
     12github.setup    ${name} ${name} 2.0.0.2-1 v
    1313version         [string map {- .} ${version}]
    1414fetch.type      git
     
    3030supported_archs noarch
    3131
    32 python.default_version  27
    33 depends_lib-append      port:py${python.version}-httplib2 \
     32python.versions 27
     33
     34depends_lib-append      port:py${python.version}-six \
     35                        port:py${python.version}-paramiko \
     36                        port:py${python.version}-httplib2 \
    3437                        port:py${python.version}-jinja2 \
    35                         port:py${python.version}-paramiko \
    36                         port:py${python.version}-yaml
     38                        port:py${python.version}-yaml \
     39                        port:py${python.version}-setuptools \
     40                        port:py${python.version}-crypto
     41
     42depends_build-append    port:asciidoc
    3743
    3844post-fetch {
    3945    # fetch submodules (https://github.com/ansible/ansible/issues/11199)
    40     system -W ${worksrcpath} "git submodule update --init"
     46    system -W "${worksrcpath}" "git submodule update --init"
    4147}
    4248
     
    4854        }
    4955    }
     56}
     57
     58post-build {
     59    system -W "${worksrcpath}" "make docs"
    5060}
    5161
Note: See TracChangeset for help on using the changeset viewer.