Changeset 145610


Ignore:
Timestamp:
Feb 10, 2016, 10:00:57 PM (2 years ago)
Author:
ciserlohn@…
Message:

nodejs: update to version 4.3.0; patch gyp so that the build no longer conflicts with c-ares and v8

Location:
trunk/dports/devel/nodejs
Files:
1 added
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/devel/nodejs/Portfile

    r144943 r145610  
    44PortSystem              1.0
    55PortGroup               compiler_blacklist_versions 1.0
    6 PortGroup               conflicts_build 1.0
    7 
    8 # see https://github.com/nodejs/node/issues/2637
    9 conflicts_build         c-ares v8
    106
    117name                    nodejs
    12 version                 4.2.6
     8version                 4.3.0
    139
    1410categories              devel net
     
    2925master_sites            ${homepage}dist/v${version}
    3026
    31 checksums               rmd160  174fa292da5b84df6aeae105c5965f00b9a07c8f \
    32                         sha256  ea5e357db8817052b17496d607c719d809ed1383e8fcf7c8ffc5214e705aefdd
     27checksums               rmd160  873f1237a68376106b75a69c7ec08a51de2c67ca \
     28                        sha256  18504ac6d903cd061f60a29dafcda416a078112f3404d23a7901c41a8e9706b9
    3329
    3430distname                node-v${version}
     
    4743
    4844configure.python ${prefix}/bin/python2.7
     45
     46patchfiles              patch-common.gypi.diff patch-tools-gyp-pylib-gyp-generator-make.py.diff
    4947
    5048post-patch {
     
    103101
    104102universal_variant       no
    105 
    106 patchfiles-append       patch-common.gypi.diff
    107103
    108104# "V8 doesn't like cache."
Note: See TracChangeset for help on using the changeset viewer.