Changeset 145935


Ignore:
Timestamp:
Feb 21, 2016, 5:52:59 PM (3 years ago)
Author:
cal@…
Message:

cpio: 2.12, fix CVE-2016-2037, ignoring maintainer

Update cpio to 2.12 and apply a patch to fix CVE-2016-2037. See

https://security-tracker.debian.org/tracker/CVE-2016-2037

for more information and

https://lists.gnu.org/archive/html/bug-cpio/2016-01/msg00005.html

for a patch.

Additionally, drop a patch that's no longer required with 2.12.

Ignoring maintainer because this is a security update.

Location:
trunk/dports/archivers/cpio
Files:
1 added
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/archivers/cpio/Portfile

    r89837 r145935  
    44
    55name                cpio
    6 version             2.11
    7 revision            2
     6version             2.12
     7revision            0
     8checksums           rmd160  156e7852db0f83e35fc02c007a1fb21e4a3393d6 \
     9                    sha256  70998c5816ace8407c8b101c9ba1ffd3ebbecba1f5031046893307580ec1296e
     10
    811categories          archivers
    912platforms           darwin
     
    1720homepage            http://www.gnu.org/software/cpio/cpio.html
    1821master_sites        gnu
    19 checksums           md5     20fc912915c629e809f80b96b2e75d7d \
    20                     sha1    6f1934b0079dc1e85ddff89cabdf01adb3a74abb \
    21                     rmd160  52507b8ba556dca888ce1179cfda10f9549ea9ab
    2222use_bzip2           yes
    2323
    2424depends_lib         port:gettext port:libiconv
    2525
    26 patchfiles          patch-src-filetypes.h.diff
     26patchfiles          cve-2016-2037.patch
    2727
    2828configure.args      --program-prefix=gnu \
Note: See TracChangeset for help on using the changeset viewer.