Changeset 146155


Ignore:
Timestamp:
Mar 1, 2016, 12:39:48 PM (3 years ago)
Author:
mojca@…
Message:

wxWidgets-1.0.tcl: remove wxPerl and change order in if-else (cosmetic change)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/_resources/port1.0/group/wxWidgets-1.0.tcl

    r122791 r146155  
    100100            }
    101101        }
     102    } elseif {${args} eq "wxPython-3.0"} {
     103        wxWidgets.name      "wxPython"
     104        wxWidgets.version   "3.0"
     105        wxWidgets.port      "wxPython-3.0"
     106        if {${os.major} < 9} {
     107            pre-fetch {
     108                ui_error "${wxWidgets.port} requires Mac OS X 10.5 or later."
     109                return -code error "incompatible Mac OS X version"
     110            }
     111        }
    102112    # ugly workaround to allow some C++11-only applications to be built on < 10.9
    103113    } elseif {${args} eq "wxWidgets-3.0-libcxx"} {
     
    111121            }
    112122        }
    113     } elseif {${args} eq "wxPython-3.0"} {
    114         wxWidgets.name      "wxPython"
    115         wxWidgets.version   "3.0"
    116         wxWidgets.port      "wxPython-3.0"
    117         if {${os.major} < 9} {
    118             pre-fetch {
    119                 ui_error "${wxWidgets.port} requires Mac OS X 10.5 or later."
    120                 return -code error "incompatible Mac OS X version"
    121             }
    122         }
    123     # support for wxPerl was just temporary
    124     } elseif {${args} eq "wxPerl-3.0"} {
    125         # throw an error
    126         ui_error "You shouldn't be using 'wxWidgets.use wxPerl-3.0' any longer. Switch to wxWidgets-3.0."
    127         return -code error "invalid parameter for wxWidgets.use"
    128123    # preliminary support for wxWidgets 3.1/3.2
    129124    } elseif {${args} eq "wxWidgets-3.2"} {
Note: See TracChangeset for help on using the changeset viewer.