Ignore:
Timestamp:
Mar 2, 2016, 1:13:21 PM (4 years ago)
Author:
easieste@…
Message:

finance/bicoin: update to bitcoin-0.12.0

N.b. the build of the GUI client is still not working, even though
some lines of the portfile related to building have been changed.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/finance/bitcoin/Portfile

    r142508 r146244  
    66name                bitcoin
    77categories          finance crypto
    8 version             0.11.2
     8version             0.12.0
    99platforms           darwin
    1010license             MIT
     
    2020master_sites        ${homepage}bin/bitcoin-core-${version}/
    2121
    22 checksums           rmd160  df541d9ac63bbea19f8d021326293270cea50dfa \
    23                     sha256  a4d2bd642e5f7f1f82dc3f708618ac77e1e45353db7a98bf81c3bdc0e10690d3
     22checksums           rmd160  aa6a5601ee4e778a2e52cb16b79e5a5e89ca92bb \
     23                    sha256  0f1cda66c841a548a07cc37e80b0727354b1236d9f374c7d44362acdb85eb3e1
    2424
    2525depends_build       port:pkgconfig \
     
    3636use_parallel_build  no
    3737
    38 #patchfiles      \
    39 #    src-rpcrawtransaction.cpp.diff # for 0.10.1
    40 
    4138configure.args      --disable-ccache \
    4239                    --disable-silent-rules
    4340
    44 # TODO: Restore GUI: needs to move to qt5, as it doesn't look like qt4 is going to get fixed.
     41# TODO: Restore GUI: needs to move to qt5, as it doesn't look like qt4
     42# is going to get fixed.
    4543default_variants     +daemon
    4644
    47 variant gui description {NOT WORKING Build with qt4 (Broken in qt4 moc inclusion of boost headers) } {
    48     configure.cmd-append    --with-gui=qt4
    49     depends_lib-append      port:qt4-mac
    50     build.args-add          appbundle
     45variant gui description {NOT WORKING Build with qt5} {
     46    configure.cmd-append    --with-gui=qt5
     47    depends_lib-append      port:qt5
    5148}
    5249
    5350variant daemon description {Build and install only the bitcoind daemon} {
    5451    configure.cmd-append    --with-gui=no
    55     build.args-delete       appbundle
    5652}
    5753
Note: See TracChangeset for help on using the changeset viewer.