Changeset 147493 for trunk/dports/www


Ignore:
Timestamp:
Apr 5, 2016, 8:30:36 PM (3 years ago)
Author:
cal@…
Message:

nghttp2: Add python35 variant, #51060

Patch from maintainer, closes #51060.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/www/nghttp2/Portfile

    r147481 r147493  
    77
    88github.setup        tatsuhiro-t nghttp2 1.9.2 v
    9 set PythonVersion   2.7
    10 set PythonBranch    [join [lrange [split ${PythonVersion} .] 0 1] ""]
    119categories          www
    1210platforms           darwin
     
    2422checksums           rmd160 ef40a5c6782294116863e22890c0a74a54715fdb \
    2523                    sha256 3d600ef8bfd151769559bc23806877b8b4eaf3d66776e6c1427b9c04cce8e853
     24
     25if {![variant_isset python35]} { default_variants +python27 }
     26
     27if {![variant_isset python27] && ![variant_isset python35]} {
     28    error "You must select one of the python variants."
     29}
     30
     31if {[variant_isset python27]} { set PythonVersion   2.7 }
     32if {[variant_isset python35]} { set PythonVersion   3.5 }
     33set PythonBranch    [join [lrange [split ${PythonVersion} .] 0 1] ""]
    2634
    2735depends_build       port:pkgconfig
     
    4755                    OPENSSL_CFLAGS=-I${prefix}/include/openssl \
    4856                    OPENSSL_LIBS="-L${prefix}/lib -lcrypto -lssl" \
    49                     PYTHON=${prefix}/bin/python${PythonVersion} \
    50                     PYTHON_EXTRA_LDFLAGS="-u _PyMac_Error ${frameworks_dir}/Python.framework/Versions/${PythonVersion}/Python"
     57                    PYTHON=${prefix}/bin/python${PythonVersion}
    5158
    5259destroot.env        PYTHONPATH=${destroot}${prefix}/lib/python${PythonVersion}/site-packages/
     
    5562    xinstall -d ${destroot}${prefix}/lib/python${PythonVersion}/site-packages/
    5663}
     64
     65variant python27 conflicts python35 description {Build using Python 2.7} {
     66    configure.env-append   PYTHON_EXTRA_LDFLAGS="-u _PyMac_Error ${frameworks_dir}/Python.framework/Versions/${PythonVersion}/Python"
     67}
     68
     69variant python35 conflicts python27 description {Build using Python 3.5} {}
Note: See TracChangeset for help on using the changeset viewer.