Changeset 148700 for trunk/dports/math


Ignore:
Timestamp:
May 15, 2016, 10:27:15 AM (3 years ago)
Author:
mcalhoun@…
Message:

octave-devel, octave-devel-rc, octave-devel-release: patch header libcxx-fix.h must be installed if used

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/math/octave-devel/Portfile

    r148699 r148700  
    3131if { ${name} eq ${subport} } {
    3232    version         ${version_tip}
    33     revision        10
     33    revision        11
    3434    hg.tag          225d88a97104
    3535
     
    4848subport octave-devel-rc {
    4949    version         ${version_rc}
    50     revision        4
     50    revision        5
    5151    hg.tag          2b66f30a0de7
    5252
     
    7373subport octave-devel-release {
    7474    version         ${version_release}
    75     #revision        0
     75    revision        1
    7676    hg.tag          5162cdfb56d8
    7777
     
    663663        ${destroot}${prefix}/share/icons/hicolor/scalable/apps/octave.svg \
    664664        ${destroot}${prefix}/share/octave/${version}/icons/hicolor/scalable/apps/octave.svg
     665
     666    if {[file exists ${worksrcpath}/liboctave/operators/libcxx-fix.h]} {
     667        # install the libc++ fix, no matter if used or not, since it is
     668        # required for projects including these headers.
     669        xinstall -m 644 ${worksrcpath}/liboctave/operators/libcxx-fix.h \
     670            ${destroot}${prefix}/include/${name}-${version}/${name}/libcxx-fix.h
     671    }
    665672}
    666673
Note: See TracChangeset for help on using the changeset viewer.