Changeset 15056


Ignore:
Timestamp:
Nov 17, 2005, 4:52:49 AM (15 years ago)
Author:
jberry
Message:

Reported by: Greg Kick

Force commons-el to compile with source compatibility set to java 1.4, so that the compiler
doesn't blow up on variables named enum. Allows it to be built with java CurrentJDK set to
1.5.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/java/commons-el/Portfile

    r11905 r15056  
    1 # $Id: Portfile,v 1.4 2005/04/19 18:15:05 jberry Exp $
     1# $Id: Portfile,v 1.5 2005/11/17 04:52:49 jberry Exp $
    22
    33PortSystem 1.0
     
    55name                            commons-el
    66version                         1.0
     7revision                        1
    78
    89categories                      java
     
    3536                                        -Djspapi.build.notrequired=true
    3637
     38post-patch {
     39        # Force source 1.4 so javac doesn't blow up on variables named enum
     40        reinplace {s|<javac |<javac source="1.4" |} ${worksrcpath}/build.xml
     41}
     42
    3743pre-build {
    3844        system "touch ${workpath}/LICENSE"
Note: See TracChangeset for help on using the changeset viewer.