Changeset 154241


Ignore:
Timestamp:
Oct 25, 2016, 9:03:26 AM (4 years ago)
Author:
vince@…
Message:

grass7: add postgresql96 option and deprecate postgresql94

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/gis/grass7/Portfile

    r148772 r154241  
    101101}
    102102
    103 variant postgresql94 description {Add PostgreSQL 9.4 support} {
    104     depends_lib-append    port:postgresql94
     103variant postgresql96 description {Add PostgreSQL 9.6 support} \
     104    conflicts postgresql95 {
     105    depends_lib-append    port:postgresql96
    105106    configure.args-delete --without-postgres
    106107    configure.args-append --with-postgres
    107     configure.args-append --with-postgres-includes=${prefix}/include/postgresql94
    108     configure.args-append --with-postgres-libs=${prefix}/lib/postgresql94
     108    configure.args-append --with-postgres-includes=${prefix}/include/postgresql96
     109    configure.args-append --with-postgres-libs=${prefix}/lib/postgresql96
    109110}
    110111
    111 variant postgresql95 description {Add PostgreSQL 9.5 support} {
     112variant postgresql95 description {Add PostgreSQL 9.5 support} \
     113    conflicts postgresql96 {
    112114    depends_lib-append    port:postgresql95
    113115    configure.args-delete --without-postgres
Note: See TracChangeset for help on using the changeset viewer.