Ignore:
Timestamp:
Jan 5, 2003, 9:41:13 PM (17 years ago)
Author:
mij
Message:

Replace the language variants with a ui_msg telling users they need to
install one of the dictionaries too in order for things to work.

Requested by: landonf

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/textproc/aspell/Portfile

    r1491 r1567  
    1414master_sites    ftp://ftp.gnu.org/gnu/aspell/
    1515
    16 checksums       aspell-0.50.3.tar.gz md5 a3bf0d46303ffb0beab8121bbc3311a3
     16checksums       md5 a3bf0d46303ffb0beab8121bbc3311a3
    1717
    1818configure.env   LIBS="-L${prefix}/lib" CPPFLAGS="-I${prefix}/include \
     
    2020configure.args  --disable-shared --enable-dict-dir="${prefix}/share/aspell"
    2121
    22 default_variants +en
    23 
    24 variant de      { post-install \
    25                   { system "cd ../aspell-dict-de && port install" } }
    26 
    27 variant dk      { post-install \
    28                   { system "cd ../aspell-dict-dk && port install" } }
    29 
    30 variant en      { post-install \
    31                   { system "cd ../aspell-dict-en && port install" } }
    32 
    33 variant es      { post-install \
    34                   { system "cd ../aspell-dict-es && port install" } }
    35 
    36 variant fr      { post-install \
    37                   { system "cd ../aspell-dict-fr && port install" } }
    38 
    39 variant it      { post-install \
    40                   { system "cd ../aspell-dict-it && port install" } }
    41 
    42 variant nl      { post-install \
    43                   { system "cd ../aspell-dict-nl && port install" } }
    44 
    45 variant ru      { post-install \
    46                   { system "cd ../aspell-dict-ru && port install" } }
     22post-install    { ui_msg "\nYou must install one of the language dictionaries after installing\nthis port in order for it to work.\n" }
    4723
    4824include         contents
Note: See TracChangeset for help on using the changeset viewer.