Changeset 15713 for trunk/doc


Ignore:
Timestamp:
Jan 7, 2006, 9:48:27 AM (13 years ago)
Author:
olegb
Message:

Bug: 2468
Submitted by: jberry@ olegb@
Reviewed by:
Approved by:
Obtained from:
add information on:

  • port installed
  • port outdated
  • port dependents
File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/doc/guide/xml/user/user.xml

    r15331 r15713  
    405405
    406406                                <varlistentry>
    407                                         <term>Getting Info about a Port</term>
     407                                        <term>Getting Information about a Port</term>
    408408
    409409                                        <listitem>
     
    417417
    418418                                <varlistentry>
    419                                         <term>Listing Ports</term>
     419                                        <term>Listing available Ports</term>
    420420
    421421                                        <listitem>
     
    430430
    431431                                                <para><userinput>port list</userinput></para>
     432                                        </listitem>
     433                                </varlistentry>
     434
     435                                <varlistentry>
     436                                        <term>Discovering which ports are installed</term>
     437
     438                                        <listitem>
     439                                                <para>To determine which ports have been installed, and
     440                                                what their versions are, use:</para>
     441
     442                                                <para><userinput>port installed</userinput></para>
     443
     444                                                <para>To determine the installed version of a particular port,
     445                                                use:</para>
     446
     447                                                <para><userinput>port installed &lt;portname&gt;</userinput></para>
     448                                        </listitem>
     449                                </varlistentry>
     450
     451                                <varlistentry>
     452                                        <term>Discovering which ports are out-of-date</term>
     453
     454                                        <listitem>
     455                                                <para>To determine which ports are out-of-date (the current
     456                                                Portfile provides a newer version than the installed version
     457                                                of the port) use:</para>
     458
     459                                                <para><userinput>port outdated</userinput></para>
    432460                                        </listitem>
    433461                                </varlistentry>
     
    463491
    464492                                                <para><userinput>port deps vile</userinput></para>
     493
     494                                                <para>If you want to find out which ports depends on a
     495                                                port you have installed, use:</para>
     496
     497                                                <para><userinput>port dependents gettext</userinput></para>
    465498                                        </listitem>
    466499                                </varlistentry>
     
    513546                        <userinput>sudo port -n upgrade gnome</userinput>
    514547                        <para>To upgrade all installed ports simply do:</para>
    515                         <userinput>sudo port -a upgrade</userinput>
     548                        <userinput>sudo port upgrade installed</userinput>
    516549                        <para>If you dont like that upgrade just deactivates the old version
    517550                        of the port, you can get it to uninstall the old version by using
Note: See TracChangeset for help on using the changeset viewer.