Ignore:
Timestamp:
Mar 11, 2006, 9:17:22 PM (15 years ago)
Author:
rhwood
Message:

Bug: NONE
Submitted by: rhwood@…
Reviewed by:
Approved by:
Obtained from:

Remove unnecessary dependencies.
Add +use-sys-deps variant to allow packages outside of DarwinPorts to satisfy dependencies

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/gnome/libgnomecanvas/Portfile

    r14034 r16891  
    1 # $Id: Portfile,v 1.17 2005/09/12 12:55:35 olegb Exp $
     1# $Id: Portfile,v 1.18 2006/03/11 21:17:22 rhwood Exp $
    22PortSystem 1.0
    33name            libgnomecanvas
     
    1919
    2020depends_lib \
    21         lib:libatk-1.0:atk lib:libgettextlib:gettext lib:libpng:libpng \
    22         lib:libglib-2.0:glib2 lib:libgtk-x11-2.0:gtk2 port:fontconfig \
    23         lib:libart_lgpl_2:libart_lgpl port:libxml2 port:xrender lib:libiconv:libiconv \
    24         lib:libpangoft2-1.0:pango port:Xft2 port:zlib port:freetype \
    25         lib:libcairo:cairo lib:libexpat:expat lib:libjpeg:jpeg lib:libtiff:tiff \
    26         lib:libglade-2.0:libglade2
     21    port:libart_lgpl \
     22        port:libglade2
    2723
    2824use_bzip2       yes
     
    3026configure.args  --mandir=${prefix}/share/man
    3127configure.env   CPPFLAGS="-L${prefix}/lib -I${prefix}/include"
     28
     29variant use-sys-deps {
     30        depends_lib \
     31        lib:libart_lgpl_2:libart_lgpl \
     32                lib:libglade-2.0:libglade2
     33}
Note: See TracChangeset for help on using the changeset viewer.