Changeset 20323


Ignore:
Timestamp:
Nov 1, 2006, 11:12:51 PM (14 years ago)
Author:
stechert@…
Message:

When trying "sudo port install evince" with a gnome-free /opt/local, I got
the following error message after lots of gnome dependencies were built:

checking for LIB... configure: error: Package requirements (gtk+-2.0 >= 2.8.15

libgnomeui-2.0 >= 2.14.0) were not met:

No package 'libgnomeui-2.0' found
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables LIB_CFLAGS
and LIB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
Error: Status 1 encountered during processing.

Obviously, there's a missing dependency on libgnomeui. After sudo port install
libgnomeui, everything builds, installs, and works great. This change just
records that dependency.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/gnome/evince/Portfile

    r20299 r20323  
    1515        bin:gs:ghostscript \
    1616        lib:libgnomeprintui-2:libgnomeprintui \
    17         lib:libpoppler:poppler
     17        lib:libpoppler:poppler \
     18        port:libgnomeui
    1819depends_build   \
    1920        bin:gnome-doc-prepare:gnome-doc-utils
Note: See TracChangeset for help on using the changeset viewer.