Ignore:
Timestamp:
Jul 16, 2007, 1:46:22 AM (12 years ago)
Author:
rhwood@…
Message:

Rework dependencies and configure.args due to upstream advice
Remove worthless configure.env settings
Whitespace changes to puredarwin variant (does anyone use this OS anymore?)
No upgrade to version 2.0.9 due to strange build failure and closeness of 2.1.0
release with Aqua UI.
Remove dependency on imlib (which depends on gtk1/glib1)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/games/freeciv/Portfile

    r26896 r27030  
    1212
    1313master_sites    sourceforge:freeciv ftp://ftp.freeciv.org/freeciv/stable/
    14 checksums       sha1 b9098dc46ed169e053f9c7405cc3abf9cebe9792
     14checksums       sha1 b9098dc46ed169e053f9c7405cc3abf9cebe9792
    1515
    1616use_bzip2           yes
    1717
    18 depends_lib     port:gettext port:libsdl port:esound port:readline port:imlib \
    19                 port:gtk2
     18depends_lib     \
     19        port:gettext \
     20        port:libsdl \
     21        port:libsdl_mixer \
     22        port:esound \
     23        port:readline \
     24        port:gtk2
    2025
    21 configure.env   LDFLAGS="-L${prefix}/lib" \
    22                 CFLAGS="-I${prefix}/include" \
    23                 CPPFLAGS="-I${prefix}/include"
    24 
    25 configure.args  --enable-client=gtk2 --with-readline --with-zlib
     26configure.args  \
     27        --enable-client=gtk2 \
     28        --with-readline \
     29        --with-zlib \
     30        --enable-nls \
     31        --with-sdl-prefix=${prefix} \
     32        --with-libiconv-prefix=${prefix}
    2633
    2734platform puredarwin {
    28                 depends_lib-delete lib:libSDL:libsdl
    29                 configure.args-append --disable-sdl-mixer
    30                 }
     35        depends_lib-delete port:libsdl
     36        configure.args-append --disable-sdl-mixer
     37}
Note: See TracChangeset for help on using the changeset viewer.