Ignore:
Timestamp:
Aug 9, 2007, 1:22:56 PM (11 years ago)
Author:
nox@…
Message:

libsdl:

  • Last commit on this port broke the QuickTime version check, this one fixes it.
File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/devel/libsdl/Portfile

    r27578 r27590  
    4545        while {[gets $qt_header line] != -1} {
    4646                        if {[regexp {Version:} $line]} {
    47                 regexp {(\d+)\.(\d+)$} $line _ qt_min qt_rev
     47                regexp {(\d+)\.(\d+)(?:\.(\d+))?$} $line qt_ver qt_maj qt_min qt_rev
    4848
    49                 if {$qt_min > 0 || $qt_rev > 3} {
     49                if {$qt_maj > 7 || $qt_min > 0 || $qt_rev > 3} {
    5050                    ui_error ""
    5151                    ui_error "Installation of libSDL is exiting because it believes you have"
    52                     ui_error "QuickTime version 7.${qt_min}.${qt_rev} installed."
     52                    ui_error "QuickTime version ${qt_ver} installed."
    5353                    ui_error ""
    5454                    ui_error "On Mac OS 10.3/XCode 1.5, you must have QuickTime 7.0.3 or lower if"
    5555                    ui_error "you want to install the libSDL port."
    5656                    ui_error ""
    57                     ui_error "If you have QuickTime 7.0.4, you can downgrade to 7.0.1:"
    58                     ui_error "http://www.apple.com/support/downloads/quicktime701reinstallerforquicktime704.html"
    59                     ui_error ""
    60                     ui_error "If you actually have QuickTime 7.0.1 and you think you should not be"
     57                                ui_error "If you actually have QuickTime 7.0.3 or below and you think you should not be"
    6158                    ui_error "receiving this error message, you can report the problem here:"
    6259                    ui_error "http://trac.macports.org/projects/macports/ticket/6533"
Note: See TracChangeset for help on using the changeset viewer.