Changeset 30477


Ignore:
Timestamp:
Oct 28, 2007, 11:00:12 PM (12 years ago)
Author:
afb@…
Message:

lessen warning for newer Xcodes

Location:
trunk/base
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/base/configure

    r30388 r30477  
    21262126
    21272127case "$XCODE_VERSION" in
    2128   1.[0-4]*|2.[0-3]*)
     2128  1.[0-1]*|2.[0-1]*)
    21292129    { echo "$as_me:$LINENO: WARNING: This version of Xcode Tools is not supported" >&5
    21302130echo "$as_me: WARNING: This version of Xcode Tools is not supported" >&2;}
    21312131    { echo "$as_me:$LINENO: WARNING: Please upgrade at http://connect.apple.com/" >&5
    21322132echo "$as_me: WARNING: Please upgrade at http://connect.apple.com/" >&2;}
     2133    ;;
     2134  1.[2-4]*|2.[2-3]*)
     2135    { echo "$as_me:$LINENO: WARNING: This version of Xcode Tools is out of date" >&5
     2136echo "$as_me: WARNING: This version of Xcode Tools is out of date" >&2;}
     2137    { echo "$as_me:$LINENO: WARNING: Please consider upgrading" >&5
     2138echo "$as_me: WARNING: Please consider upgrading" >&2;}
    21332139    ;;
    21342140  1.5*|2.4*|3.*)
  • trunk/base/configure.ac

    r30388 r30477  
    4141
    4242case "$XCODE_VERSION" in
    43   1.[[0-4]]*|2.[[0-3]]*)
     43  1.[[0-1]]*|2.[[0-1]]*)
    4444    AC_WARN(This version of Xcode Tools is not supported)
    4545    AC_WARN(Please upgrade at http://connect.apple.com/)
     46    ;;
     47  1.[[2-4]]*|2.[[2-3]]*)
     48    AC_WARN(This version of Xcode Tools is out of date)
     49    AC_WARN(Please consider upgrading, some ports fail)
    4650    ;;
    4751  1.5*|2.4*|3.*)
Note: See TracChangeset for help on using the changeset viewer.