Ignore:
Timestamp:
Dec 14, 2007, 7:01:31 PM (13 years ago)
Author:
eridius@…
Message:

Fix the message takanori made of my MacFUSE portfiles.
In the future, please don't make changes to my Portfiles without telling me

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/fuse/fusefs/Portfile

    r31527 r32055  
    66name                fusefs
    77version             1.1
    8 revision            2
     8revision            3
    99categories          fuse devel
    1010platforms           darwin
     
    2020homepage            http://code.google.com/p/macfuse/
    2121master_sites        macports
    22 distname            macfuse-${version}
    23 checksums           md5 42487d7684b1f9a8eb2f8a61b10f7913 \
    24                     sha1 6347e5b6b0f810a3e5b0fbc82cbccfdf3f4c6311
     22distname            fusefs-${version}
     23worksrcdir          fusefs
     24checksums           md5 e34f44bcbb43a370a0ef204054276ae4 \
     25                    sha1 776a7cf88c82bf63a8f086f086d06fb08a60c860
    2526
    26 platform darwin 8 {}
    27 
    28 if {[variant_isset darwin_8]} {
    29     set product_version 10.4
    30 } else {
    31     set product_version 10.5
    32 }
    33 
    34 worksrcdir          ${distname}/core/${product_version}/${name}
    35 livecheck.distname  MacFUSE-Core-${product_version}-(.*).dmg
     27livecheck.distname  MacFUSE-Core-(.*).dmg
     28livecheck.version   10.5-${version}.1
    3629
    3730use_bzip2           yes
     
    4336xcode.build.settings    OBJROOT=build/ SYMROOT=build/
    4437
    45 # ensure that user is running OS X 10.4
     38platform darwin 8 {
     39    worksrcdir fusefs/10.4
     40}
     41
     42platform darwin 9 {
     43    worksrcdir fusefs/10.5
     44}
     45
     46# ensure that user is running OS X 10.4 or higher
    4647pre-fetch {
    47     if {${os.platform} == "darwin"} {
    48         set vers [split [exec sw_vers -productVersion] .]
    49         set majorVersion [lindex $vers 0]
    50         set minorVersion [lindex $vers 1]
    51         if {"$majorVersion.$minorVersion" < 10.4} {
    52             return -code error "MacFUSE requires at least Mac OS X 10.4 to run"
    53         }
    54     } else {
    55         return -code error "MacFUSE is for Mac OS X only"
     48    if {![variant_isset darwin_8] && ![variant_isset darwin_9]} {
     49        return -code error "MacFUSE requires at least Mac OS X 10.4 to run"
    5650    }
    5751}
     
    8680        file attributes $file -owner root -group wheel
    8781    }
     82   
     83    # copy header files that libfuse needs
     84    foreach file [list fuse_ioctl.h fuse_mount.h fuse_param.h fuse_version.h] {
     85        file copy -- ${worksrcpath}/common/${file} ${destroot}${prefix}/include/${file}
     86    }
    8887}
    8988
Note: See TracChangeset for help on using the changeset viewer.